summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Sarnie <sarnex@gentoo.org>2021-03-27 20:03:18 -0400
committerNick Sarnie <sarnex@gentoo.org>2021-03-27 20:36:39 -0400
commita9220e21a841c846ac2640ae5f1387746b776358 (patch)
tree04e6843a803606579bf70562d8e0fd786d7ba887 /dev-util/glslang/glslang-11.2.0.ebuild
parentx11-libs/fltk: drop project desktop-misc (diff)
downloadgentoo-a9220e21a841c846ac2640ae5f1387746b776358.tar.gz
gentoo-a9220e21a841c846ac2640ae5f1387746b776358.tar.bz2
gentoo-a9220e21a841c846ac2640ae5f1387746b776358.zip
dev-util/glslang: Version bump
Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Nick Sarnie <sarnex@gentoo.org>
Diffstat (limited to 'dev-util/glslang/glslang-11.2.0.ebuild')
-rw-r--r--dev-util/glslang/glslang-11.2.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-util/glslang/glslang-11.2.0.ebuild b/dev-util/glslang/glslang-11.2.0.ebuild
new file mode 100644
index 000000000000..2fe500d17138
--- /dev/null
+++ b/dev-util/glslang/glslang-11.2.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CMAKE_ECLASS="cmake"
+PYTHON_COMPAT=( python3_{7,8,9} )
+inherit cmake-multilib python-any-r1
+
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/KhronosGroup/${PN}.git"
+ inherit git-r3
+else
+ SNAPSHOT_COMMIT="${PV}"
+ SRC_URI="https://github.com/KhronosGroup/${PN}/archive/${SNAPSHOT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+ S="${WORKDIR}/${PN}-${SNAPSHOT_COMMIT}"
+fi
+
+DESCRIPTION="Khronos reference front-end for GLSL and ESSL, and sample SPIR-V generator"
+HOMEPAGE="https://www.khronos.org/opengles/sdk/tools/Reference-Compiler/ https://github.com/KhronosGroup/glslang"
+
+LICENSE="BSD"
+SLOT="0"
+
+RDEPEND="!<media-libs/shaderc-2020.1"
+BDEPEND="${PYTHON_DEPS}"
+
+# Bug 698850
+RESTRICT="test"