summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2020-07-18 09:35:35 -0400
committerMike Gilbert <floppym@gentoo.org>2020-07-18 09:35:52 -0400
commitdc7d3a9edfb07f6dd1ce561e3fa223f71f65e141 (patch)
tree4615826d571de5a29e1845557622111f00a87866 /dev-util/gn
parentdev-util/gn: bump to 0.1807 (diff)
downloadgentoo-dc7d3a9edfb07f6dd1ce561e3fa223f71f65e141.tar.gz
gentoo-dc7d3a9edfb07f6dd1ce561e3fa223f71f65e141.tar.bz2
gentoo-dc7d3a9edfb07f6dd1ce561e3fa223f71f65e141.zip
dev-util/gn: remove old
Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'dev-util/gn')
-rw-r--r--dev-util/gn/Manifest1
-rw-r--r--dev-util/gn/files/gn-gen-r1.patch57
-rw-r--r--dev-util/gn/gn-0.1463.ebuild56
3 files changed, 0 insertions, 114 deletions
diff --git a/dev-util/gn/Manifest b/dev-util/gn/Manifest
index c062fb74a31b..6297d2820055 100644
--- a/dev-util/gn/Manifest
+++ b/dev-util/gn/Manifest
@@ -1,3 +1,2 @@
-DIST gn-0.1463.tar.gz 905571 BLAKE2B e048e642704533d478fb751748a97f60283f63868ab1ab6fa5b8e7bc0322745cf21464eaa16194f684869b50f306668d3c7d3b4f72c3985b865d8492d1ff0901 SHA512 f32861a8fa44034b932e6aae4787fd7da6e4c6c19c5b6919de7b0d0f1ba20f415c1c55db95a08958a338b7b9de740ff49a29ab894a9c4e9049a89450d8c88281
DIST gn-0.1726.tar.xz 663480 BLAKE2B 26920a1594e9cc664293efaeaa8725568b78ecc1f2ac8c9a3cd27333e5fe89f1fa5bdee9e42c408f3c4a7cfb630e79220926c5694e31131d3e7627be49b5d6b2 SHA512 3e93ba02f251386c4aa320a45b8a045c2a1fa686a8f170455f3c06bb25b1a628c44530ae2e56bcbb2ff4b2a84dd065d54dde90955a55a325a8d219acce69ec2f
DIST gn-0.1807.tar.xz 682644 BLAKE2B 5beb3c03b0ae467cb98eff2069ef6e4355cba56c57e2717139b698fa563efc404dd1cf0b3fd196f432ca3a13b0402e895b46407cb90bc16b63963710fd5be060 SHA512 82f468e389d08a46e582f816d056813af9bfc810ad0bd84f02731c17c0e2c6140a62e827b8a3c5f89eef467f9bcfc2e88dd7aed325a7955d8584e753fcd09103
diff --git a/dev-util/gn/files/gn-gen-r1.patch b/dev-util/gn/files/gn-gen-r1.patch
deleted file mode 100644
index 77fdefcf222d..000000000000
--- a/dev-util/gn/files/gn-gen-r1.patch
+++ /dev/null
@@ -1,57 +0,0 @@
-diff --git a/build/gen.py b/build/gen.py
-index 76f88e84..5e088b2a 100755
---- a/build/gen.py
-+++ b/build/gen.py
-@@ -326,9 +326,6 @@ def WriteGNNinja(path, platform, host, options, linux_sysroot):
- if options.debug:
- cflags.extend(['-O0', '-g'])
- else:
-- cflags.append('-DNDEBUG')
-- cflags.append('-O3')
-- ldflags.append('-O3')
- # Use -fdata-sections and -ffunction-sections to place each function
- # or data item into its own section so --gc-sections can eliminate any
- # unused functions and data items.
-@@ -340,14 +337,6 @@ def WriteGNNinja(path, platform, host, options, linux_sysroot):
- # Garbage collection is done by default on aix.
- ldflags.append('-Wl,--gc-sections')
-
-- # Omit all symbol information from the output file.
-- if platform.is_darwin():
-- ldflags.append('-Wl,-S')
-- elif platform.is_aix():
-- ldflags.append('-Wl,-s')
-- else:
-- ldflags.append('-Wl,-strip-all')
--
- # Enable identical code-folding.
- if options.use_icf:
- ldflags.append('-Wl,--icf=all')
-@@ -356,26 +345,17 @@ def WriteGNNinja(path, platform, host, options, linux_sysroot):
- '-D_FILE_OFFSET_BITS=64',
- '-D__STDC_CONSTANT_MACROS', '-D__STDC_FORMAT_MACROS',
- '-pthread',
-- '-pipe',
- '-fno-exceptions',
- '-fno-rtti',
- ])
- cflags_cc.extend(['-std=c++14', '-Wno-c++11-narrowing'])
-+ ldflags.append('-pthread')
-
- if platform.is_linux():
- if linux_sysroot:
- # Use the sid sysroot that UpdateLinuxSysroot() downloads.
- cflags.append('--sysroot=' + linux_sysroot)
- ldflags.append('--sysroot=' + linux_sysroot)
-- ldflags.extend([
-- '-static-libstdc++',
-- '-Wl,--as-needed',
-- ])
-- libs.extend([
-- # These are needed by libc++.
-- '-ldl',
-- '-lpthread',
-- ])
- elif platform.is_darwin():
- min_mac_version_flag = '-mmacosx-version-min=10.9'
- cflags.append(min_mac_version_flag)
diff --git a/dev-util/gn/gn-0.1463.ebuild b/dev-util/gn/gn-0.1463.ebuild
deleted file mode 100644
index 6ef882d71205..000000000000
--- a/dev-util/gn/gn-0.1463.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python2_7 )
-
-inherit ninja-utils python-any-r1 toolchain-funcs
-
-DESCRIPTION="GN is a meta-build system that generates build files for Ninja"
-HOMEPAGE="https://gn.googlesource.com/"
-SRC_URI="https://dev.gentoo.org/~floppym/dist/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~x86"
-
-BDEPEND="
- ${PYTHON_DEPS}
- dev-util/ninja
-"
-
-PATCHES=(
- "${FILESDIR}"/gn-gen-r1.patch
-)
-
-pkg_setup() {
- :
-}
-
-src_configure() {
- python_setup
- tc-export AR CC CXX
- set -- ${EPYTHON} build/gen.py --no-sysroot --no-last-commit-position
- echo "$@"
- "$@" || die
- cat >out/last_commit_position.h <<-EOF || die
- #ifndef OUT_LAST_COMMIT_POSITION_H_
- #define OUT_LAST_COMMIT_POSITION_H_
- #define LAST_COMMIT_POSITION "${PV}"
- #endif // OUT_LAST_COMMIT_POSITION_H_
- EOF
-}
-
-src_compile() {
- eninja -C out gn
-}
-
-src_test() {
- eninja -C out gn_unittests
- out/gn_unittests || die
-}
-
-src_install() {
- dobin out/gn
- einstalldocs
-}