summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/kdevelop-qmake
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/kdevelop-qmake')
-rw-r--r--dev-util/kdevelop-qmake/Manifest2
-rw-r--r--dev-util/kdevelop-qmake/kdevelop-qmake-1.6.0.ebuild31
-rw-r--r--dev-util/kdevelop-qmake/kdevelop-qmake-1.7.0.ebuild39
-rw-r--r--dev-util/kdevelop-qmake/metadata.xml8
4 files changed, 80 insertions, 0 deletions
diff --git a/dev-util/kdevelop-qmake/Manifest b/dev-util/kdevelop-qmake/Manifest
new file mode 100644
index 000000000000..1a909e1d20c3
--- /dev/null
+++ b/dev-util/kdevelop-qmake/Manifest
@@ -0,0 +1,2 @@
+DIST kdevelop-qmake-1.6.0.tar.gz 65997 SHA256 d6e1988014d2dd3ec88835aec557f5c95a307276beb6315cf839ba7330028e96 SHA512 ff96cb0351edbdfea5a7040f663a808fb4bc6cf44bb1e54c4bf1ad2c836f29073734e140196ab5b20e393f6ad795a179e53f92d5e293658d80becf09d0b99852 WHIRLPOOL da3bc56f13ed67d1278d6a106baa5ad99a3c252cea11e86c464fa20985c30c7bd9cb17c5e126463905034aa8ef74d1734183ab32222e67a5b3fd6f5033f578dd
+DIST kdevelop-qmake-1.7.0.tar.gz 65864 SHA256 f0ae7b9ef570b755773c8c53917e1352dddc37fe061611fdebb3b4a1a8c62f1a SHA512 eadeefb3b927710ea5ec365e3d3e99d4f0af2a995cc18ddeeb437c0ee946b61f25b574846c8dff39bf6e0bcafce8adeb9a8ca787a429498b3cc15a7e78225e9f WHIRLPOOL aa551982dfb47b6820eed0f8fd0e7b3d08425406b6b2b6616257ea5ea47e2aed881791de0cc1b5b6b5ffa4bb60e13b7968c3a244e62cef284fe6fc2f7ce70b99
diff --git a/dev-util/kdevelop-qmake/kdevelop-qmake-1.6.0.ebuild b/dev-util/kdevelop-qmake/kdevelop-qmake-1.6.0.ebuild
new file mode 100644
index 000000000000..aea78458e194
--- /dev/null
+++ b/dev-util/kdevelop-qmake/kdevelop-qmake-1.6.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KDEBASE="kdevelop"
+KMNAME="kdev-qmake"
+inherit kde4-base
+
+MY_PN="${KMNAME}"
+S=${WORKDIR}/${MY_PN}
+DESCRIPTION="Qt's qmake build system plugin for KDevelop"
+HOMEPAGE="http://www.kdevelop.org/"
+SRC_URI="http://quickgit.kde.org/?p=${MY_PN}.git&a=snapshot&h=${PV%%.0} -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="4"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-util/kdevelop:4
+ dev-util/kdevelop-pg-qt:4
+"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ kde4-base_src_install
+ rm "${D}/usr/share/apps/kdevappwizard/templates/qmake_qt4guiapp.tar.bz2"
+}
diff --git a/dev-util/kdevelop-qmake/kdevelop-qmake-1.7.0.ebuild b/dev-util/kdevelop-qmake/kdevelop-qmake-1.7.0.ebuild
new file mode 100644
index 000000000000..a2a4d7295eba
--- /dev/null
+++ b/dev-util/kdevelop-qmake/kdevelop-qmake-1.7.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KDEBASE="kdevelop"
+KMNAME="kdev-qmake"
+inherit kde4-base
+
+DESCRIPTION="qmake plugin for KDevelop 4"
+SRC_URI="http://quickgit.kde.org/?p=${KMNAME}.git&a=snapshot&h=${PV%%.0} -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug tools"
+
+DEPEND="
+ dev-util/kdevelop:4
+ dev-util/kdevelop-pg-qt:4
+"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${KMNAME}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_build tools qmake_parser)
+ )
+ kde4-base_src_configure
+}
+
+src_install() {
+ kde4-base_src_install
+ #Move this file to prevent a collision with kappwizard
+ mv "${D}"/usr/share/apps/kdevappwizard/templates/qmake_qt4guiapp.tar.bz2 \
+ "${D}"/usr/share/apps/kdevappwizard/templates/kdevelop-qmake_qt4guiapp.tar.bz2 \
+ || die
+}
diff --git a/dev-util/kdevelop-qmake/metadata.xml b/dev-util/kdevelop-qmake/metadata.xml
new file mode 100644
index 000000000000..5a8fd6011702
--- /dev/null
+++ b/dev-util/kdevelop-qmake/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>kde</herd>
+ <use>
+ <flag name="tools">Build and install the qmake-parser debugging tool</flag>
+ </use>
+</pkgmetadata>