summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-06-06 06:57:31 +0100
committerSam James <sam@gentoo.org>2023-06-06 06:59:35 +0100
commitc310685670753b51acf5af6c3a8207a3c0fdf931 (patch)
treed3eaf0b45238bb19af4fc7357dfb7f6ce9170517 /dev-util/plan9port
parentdev-python/tempest: Remove old (diff)
downloadgentoo-c310685670753b51acf5af6c3a8207a3c0fdf931.tar.gz
gentoo-c310685670753b51acf5af6c3a8207a3c0fdf931.tar.bz2
gentoo-c310685670753b51acf5af6c3a8207a3c0fdf931.zip
dev-util/plan9port: add 0_pre20230331
Closes: https://bugs.gentoo.org/818676 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util/plan9port')
-rw-r--r--dev-util/plan9port/Manifest1
-rw-r--r--dev-util/plan9port/plan9port-0_pre20230331.ebuild144
2 files changed, 145 insertions, 0 deletions
diff --git a/dev-util/plan9port/Manifest b/dev-util/plan9port/Manifest
index 26110d5f298a..0659551716d1 100644
--- a/dev-util/plan9port/Manifest
+++ b/dev-util/plan9port/Manifest
@@ -1 +1,2 @@
DIST plan9port-88a87fadae6629932d9c160f53ad5d79775f8f94.tar.gz 23413373 BLAKE2B 6145dd77c9e4b33ebc6d68f42ed69e320e8bfcaae474a16afb3a62e30c13a39117d7013f3cc075eb48c95a5600c4fdb457e45f65f7b25ad2acc7b19dc9cf8e64 SHA512 f008969274e790238b58ebd0d0dcfaa730557daf974797f8c4014c36ac39995b330db9c6d658655358fdb2be64905b83c35e2287b7cd66b2d3249e1da1a3e119
+DIST plan9port-cc4571fec67407652b03d6603ada6580de2194dc.tar.gz 23411459 BLAKE2B 439ea7dcddfc466a7fe8bea8b75a7e73558e5cdbd7f0adf9b3367d6eab9eaab8afa8e9fb60bcf83a4a614abbd52a85ddfa65b5dd757fdd2b725f554bf66f3c90 SHA512 e347ffd04c92508b3bc324d93837c831af40b5eb11583f6c61e15c0e861067c76945a1a65929c1e725f18760035a1a14a6cd16a7b8b6a14fd2422750cef1e4d4
diff --git a/dev-util/plan9port/plan9port-0_pre20230331.ebuild b/dev-util/plan9port/plan9port-0_pre20230331.ebuild
new file mode 100644
index 000000000000..a5172d77bb8d
--- /dev/null
+++ b/dev-util/plan9port/plan9port-0_pre20230331.ebuild
@@ -0,0 +1,144 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multiprocessing toolchain-funcs readme.gentoo-r1
+
+MY_HASH="cc4571fec67407652b03d6603ada6580de2194dc"
+MY_P="${PN}-${MY_HASH}"
+
+DESCRIPTION="Port of many Plan 9 programs and libraries"
+HOMEPAGE="https://9fans.github.io/plan9port/ https://github.com/9fans/plan9port"
+SRC_URI="https://github.com/9fans/${PN}/archive/${MY_HASH}.tar.gz -> ${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="
+ MIT RSA Apache-2.0 public-domain BitstreamVera BZIP2
+ !freefonts? ( BigelowHolmes )
+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="X aqua freefonts truetype"
+REQUIRED_USE="?? ( X aqua )"
+
+DEPEND="
+ X? ( x11-apps/xauth )
+ truetype? (
+ media-libs/freetype
+ media-libs/fontconfig
+ )
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-noexecstack.patch"
+ "${FILESDIR}/${PN}-cflags.patch"
+ "${FILESDIR}/${PN}-builderr.patch"
+)
+
+PLAN9="/opt/plan9"
+EPLAN9="${EPREFIX}${PLAN9}"
+QA_MULTILIB_PATHS="${PLAN9}/.*/.*"
+
+DOC_CONTENTS="Plan 9 from User Space has been successfully installed into
+${PLAN9}. Your PLAN9 and PATH environment variables have
+also been appropriately set, please use env-update and
+source /etc/profile to bring that into immediate effect.
+
+Please note that ${PLAN9}/bin has been appended to the
+*end* or your PATH to prevent conflicts. To use the Plan9
+versions of common UNIX tools, use the absolute path:
+${PLAN9}/bin or the 9 command (eg: 9 troff)
+
+Please report any bugs to bugs.gentoo.org, NOT Plan9Port."
+DISABLE_AUTOFORMATTING="yes"
+
+src_prepare() {
+ default
+
+ if use freefonts; then
+ pushd font || die
+ rm -r big5 fixed jis luc{,m,sans} misc naga10 pelm shinonome || die
+ popd || die
+ rm -r postscript/font/luxi || die
+ fi
+
+ case "${CHOST}" in
+ *apple*)
+ sed -i 's/--noexecstack/-noexecstack/' src/mkhdr ||
+ die "Failed to sed AFLAGS" ;;
+ *)
+ rm -rf mac || die
+ esac
+
+ # don't hardcode /bin and /usr/bin in PATH
+ sed -i '/PATH/s,/bin:/usr/bin:,,' INSTALL || die "sed on INSTALL failed"
+
+ # don't hardcode /usr/{,local/}include and prefix /usr/include/*
+ sed -Ei -e 's,-I/usr(|/local)/include ,,g' \
+ -e "s,-I/usr(|/local)/include,-I${EPREFIX}/usr\1/include,g" \
+ src/cmd/fontsrv/freetyperules.sh INSTALL $(find -name makefile) ||
+ die "sed failed"
+
+ # Fix paths, done in place of ./INSTALL -c
+ einfo "Fixing hard-coded /usr/local/plan9 paths"
+ sed -i "s,/usr/local/plan9,${EPLAN9},g" $(grep -lr /usr/local/plan9) ||
+ die "sed failed"
+}
+
+src_configure() {
+ local -a myconf=(
+ CC9="$(tc-getCC)"
+ CC9FLAGS="'${CFLAGS} ${LDFLAGS}'"
+ )
+
+ if use X; then
+ myconf+=( WSYSTYPE=x11 )
+ elif use aqua; then
+ local wsystype="$(awk '{if ($1 > 10.5) print "osx-cocoa"; else print "osx"}' \
+ <<< "${MACOSX_DEPLOYMENT_TARGET}")"
+ myconf+=( WSYSTYPE="${wsystype}" )
+ else
+ myconf+=( WSYSTYPE=nowsys )
+ fi
+
+ if use truetype; then
+ myconf+=( FONTSRV=fontsrv )
+ else
+ myconf+=( FONTSRV= )
+ fi
+
+ printf '%s\n' "${myconf[@]}" >> LOCAL.config ||
+ die "cannot create configuration"
+}
+
+src_compile() {
+ # The INSTALL script builds mk then [re]builds everything using that
+ einfo "Compiling Plan 9 from User Space can take a very long time"
+ einfo "depending on the speed of your computer. Please be patient!"
+ NPROC="$(makeopts_jobs)" ./INSTALL -b ||
+ die "Please report bugs to bugs.gentoo.org, NOT Plan9Port."
+}
+
+src_install() {
+ readme.gentoo_create_doc
+
+ rm -rf src || die
+
+ # do* plays with the executable bit, and we should not modify them
+ dodir "${PLAN9}"
+ cp -a * "${ED}${PLAN9}" || die "cp failed"
+
+ # build the environment variables and install them in env.d
+ newenvd - 60plan9 <<-EOF
+ PLAN9="${EPLAN9}"
+ PATH="${EPLAN9}/bin"
+ ROOTPATH="${EPLAN9}/bin"
+ MANPATH="${EPLAN9}/man"
+ EOF
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}