summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-03-19 12:03:28 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-03-19 16:02:40 +0200
commit9b2df256900485f83dfe59aff117586add926b75 (patch)
tree6950eae4cf34cdb99b2f9eb23a8f989bf03c546f /dev-util/rosdep
parentdev-util/rosdep: fix tests (diff)
downloadgentoo-9b2df256900485f83dfe59aff117586add926b75.tar.gz
gentoo-9b2df256900485f83dfe59aff117586add926b75.tar.bz2
gentoo-9b2df256900485f83dfe59aff117586add926b75.zip
dev-util/rosdep: update live ebuild
Closes: https://bugs.gentoo.org/826642 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-util/rosdep')
-rw-r--r--dev-util/rosdep/rosdep-9999.ebuild24
1 files changed, 10 insertions, 14 deletions
diff --git a/dev-util/rosdep/rosdep-9999.ebuild b/dev-util/rosdep/rosdep-9999.ebuild
index 4db6d1249c3b..b27a854ad522 100644
--- a/dev-util/rosdep/rosdep-9999.ebuild
+++ b/dev-util/rosdep/rosdep-9999.ebuild
@@ -1,22 +1,18 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
+DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{8..10} )
-
-SCM=""
-if [ "${PV#9999}" != "${PV}" ] ; then
- SCM="git-r3"
- EGIT_REPO_URI="https://github.com/ros-infrastructure/rosdep"
-fi
-
-inherit ${SCM} distutils-r1
+inherit distutils-r1
DESCRIPTION="Command-line tool for installing ROS system dependencies"
HOMEPAGE="https://wiki.ros.org/rosdep"
-if [ "${PV#9999}" != "${PV}" ] ; then
- SRC_URI=""
+
+if [[ ${PV} = *9999 ]]; then
+ EGIT_REPO_URI="https://github.com/ros-infrastructure/rosdep"
+ inherit git-r3
else
SRC_URI="http://download.ros.org/downloads/${PN}/${P}.tar.gz
https://github.com/ros-infrastructure/rosdep/archive/${PV}.tar.gz -> ${P}.tar.gz
@@ -29,7 +25,7 @@ SLOT="0"
# Tests need network
RESTRICT="test"
-PROPERTIES+=" test_network"
+PROPERTIES="test_network"
RDEPEND="
dev-python/catkin_pkg[${PYTHON_USEDEP}]
@@ -44,7 +40,7 @@ BDEPEND="
"
PATCHES=( "${FILESDIR}/tests.patch" )
-distutils_enable_tests nose
+distutils_enable_tests pytest
src_test() {
unset ROS_DISTRO