summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-10-20 12:03:19 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-10-20 14:44:01 +0200
commit7e163c439a456705319157002e4d2c4ce84e7e8e (patch)
tree5e2b736777a963c556386a16c0906fefefbd4b8d /dev-util/rosinstall_generator/rosinstall_generator-0.1.22-r1.ebuild
parentdev-python/rosdistro: bump to 0.8.3 (diff)
downloadgentoo-7e163c439a456705319157002e4d2c4ce84e7e8e.tar.gz
gentoo-7e163c439a456705319157002e4d2c4ce84e7e8e.tar.bz2
gentoo-7e163c439a456705319157002e4d2c4ce84e7e8e.zip
dev-util/rosinstall_generator: fix distutils dep
Add py39 Closes: https://bugs.gentoo.org/749945 Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-util/rosinstall_generator/rosinstall_generator-0.1.22-r1.ebuild')
-rw-r--r--dev-util/rosinstall_generator/rosinstall_generator-0.1.22-r1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-util/rosinstall_generator/rosinstall_generator-0.1.22-r1.ebuild b/dev-util/rosinstall_generator/rosinstall_generator-0.1.22-r1.ebuild
new file mode 100644
index 000000000000..3b70d500c3cf
--- /dev/null
+++ b/dev-util/rosinstall_generator/rosinstall_generator-0.1.22-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="https://github.com/ros-infrastructure/rosinstall_generator"
+fi
+
+inherit ${SCM} distutils-r1
+
+DESCRIPTION="Generates rosinstall metadata about repositories with ROS packages/stacks"
+HOMEPAGE="https://wiki.ros.org/rosinstall_generator"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/ros-infrastructure/rosinstall_generator/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/catkin_pkg-0.1.28[${PYTHON_USEDEP}]
+ >=dev-python/rosdistro-0.5.0[${PYTHON_USEDEP}]
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+PATCHES=( "${FILESDIR}/yaml.patch" )
+
+python_test() {
+ nosetests --with-coverage || die
+}