summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-04-16 12:01:41 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-04-16 12:02:47 +0200
commit117627ad17838f77f9b33bf1f9cef66b75669e9e (patch)
tree7944aac68c0874c8be4ec07c7011d5b84cbca9c0 /dev-util/shards
parentdev-ruby/activejob: slot 7.0 add dev-ruby/zeitwerk test depend (diff)
downloadgentoo-117627ad17838f77f9b33bf1f9cef66b75669e9e.tar.gz
gentoo-117627ad17838f77f9b33bf1f9cef66b75669e9e.tar.bz2
gentoo-117627ad17838f77f9b33bf1f9cef66b75669e9e.zip
dev-util/shards: bump to 0.17.3
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-util/shards')
-rw-r--r--dev-util/shards/Manifest1
-rw-r--r--dev-util/shards/shards-0.17.3.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-util/shards/Manifest b/dev-util/shards/Manifest
index 171d70f4b140..8b5c3d536da7 100644
--- a/dev-util/shards/Manifest
+++ b/dev-util/shards/Manifest
@@ -1,3 +1,4 @@
DIST crystal-molinillo-0.2.0.tar.gz 23959 BLAKE2B 257dcca66583db87a802b27b1f100e226eb0b6ac53708d110040d7b5560f429a82f11595e303af4922f22917d922d60ea380fb395d254dc3b3ce24f4183395b6 SHA512 7c00a6a3ee4864b712ad8b703557f10498ba0b25491a55ae2f6c02d574034ec5bf8b87df777c3d34eb9cc4c87eebdcf6567c153e9edf3bc3c1b9ac4306ce3dc2
DIST shards-0.15.0.tar.gz 62648 BLAKE2B bd36733e4a98fcc4a02038745ac2b838c61109edc593a333ebb35474d5a7ecb2767c8c1a54f7116c76e83fceb59d151813d3dd23e8afc37c29f00e6b879daf3c SHA512 cbd428627c08658213494215db78c94513482aaa54038c159e8fea4819291552eda8a8f6decf5cf90134c89e98ad7fdaee5f666f02df054fb44c703179f428ca
DIST shards-0.17.2.tar.gz 72048 BLAKE2B 1aab6e12be7300918d2e39d3c529da852fd7bb085a23fb2b4c089901ca2188d8f707b5c6554d3912d06067c9cae2c559d415636445c771ec9ec620deabe408ed SHA512 a3f4343fb3e7c653f8a61384bc159ae5c1dacc97017c7895f65f425a79bfee0af080abe2a98b7a3f2a7e4b0ee4bfc05db53af724d0ffb09cbde64f848599acd1
+DIST shards-0.17.3.tar.gz 72539 BLAKE2B 2be15469df4b8a53ebd480815487f782717ce9d436cddf6acc2559e4c5dd61f06a1089d34b0a31aab2ab3e5334cd10abe513edd2cbe92b84d0fbd1cfc6cb09e5 SHA512 0789cf1fcc0df0f2d7657c034a157f05c0d65ee2c2ecda1f3d8b2d2f1274d584769f8600985fc463bc6632fe0a0822bdc40250aef2a92d1d612d0548ed0f4d2a
diff --git a/dev-util/shards/shards-0.17.3.ebuild b/dev-util/shards/shards-0.17.3.ebuild
new file mode 100644
index 000000000000..013d311a44fe
--- /dev/null
+++ b/dev-util/shards/shards-0.17.3.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multiprocessing toolchain-funcs
+
+CRYSTAL_MOLINILLO_PV=0.2.0
+CRYSTAL_MOLINILLO_P=crystal-molinillo-${CRYSTAL_MOLINILLO_PV}
+
+DESCRIPTION="Dependency manager for the Crystal language"
+HOMEPAGE="https://github.com/crystal-lang/shards/"
+SRC_URI="
+ https://github.com/crystal-lang/shards/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz
+ https://github.com/crystal-lang/crystal-molinillo/archive/v${CRYSTAL_MOLINILLO_PV}.tar.gz
+ -> ${CRYSTAL_MOLINILLO_P}.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="test" # missing files in tarball
+
+RDEPEND="
+ >dev-lang/crystal-0.11.1
+ dev-libs/libyaml:=
+"
+DEPEND="${RDEPEND}"
+
+DOCS=( CHANGELOG.md README.md SPEC.md )
+
+QA_PREBUILT=".*" # Generated by Crystal.
+
+src_prepare() {
+ default
+
+ # bundle crystal-molinillo to bootstrap 'shards'
+ mkdir -p lib || die
+ ln -s ../../${CRYSTAL_MOLINILLO_P} lib/molinillo || die
+
+ tc-export CC
+}
+
+src_compile() {
+ emake release=1 \
+ FLAGS="--link-flags=\"${LDFLAGS}\" --verbose --threads $(makeopts_jobs)"
+}
+
+src_install() {
+ exeinto /usr/bin
+ doexe bin/${PN}
+
+ doman man/*
+ einstalldocs
+}