summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-07-21 07:51:57 -0400
committerMatt Turner <mattst88@gentoo.org>2022-07-21 07:59:25 -0400
commit399cd1d4ece5603105971b37179ea7ee74b74f3d (patch)
tree896e3be3522621b76a0010ef95b07cc2f2dd2ec3 /dev-util/spirv-tools
parentdev-util/spirv-headers: Drop old versions (diff)
downloadgentoo-399cd1d4ece5603105971b37179ea7ee74b74f3d.tar.gz
gentoo-399cd1d4ece5603105971b37179ea7ee74b74f3d.tar.bz2
gentoo-399cd1d4ece5603105971b37179ea7ee74b74f3d.zip
dev-util/spirv-tools: Drop old versions
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-util/spirv-tools')
-rw-r--r--dev-util/spirv-tools/Manifest1
-rw-r--r--dev-util/spirv-tools/files/spirv-tools-1.3.211-cmake-librt.patch40
-rw-r--r--dev-util/spirv-tools/spirv-tools-1.3.211-r1.ebuild49
3 files changed, 0 insertions, 90 deletions
diff --git a/dev-util/spirv-tools/Manifest b/dev-util/spirv-tools/Manifest
index 20c4be99a67f..406db9466a87 100644
--- a/dev-util/spirv-tools/Manifest
+++ b/dev-util/spirv-tools/Manifest
@@ -1,2 +1 @@
-DIST spirv-tools-1.3.211.tar.gz 2995491 BLAKE2B 545457d097d1e00720a3f97c1f2ed0f27c7b8b6e799ac22c6adbbed7fed17edee27e13c04848db70ee08ac3319ed9a322e22a9288184651f8aa4c03df0ab4057 SHA512 df7de69779baa7ea2269cb4c9813a7d8026763f7d4f7408ea5c160ca7bd670e46e75dcbf9d99ca5f1619f37f504e695d151ede5d5cd0ef675a8898bb297c5842
DIST spirv-tools-1.3.216.tar.gz 3019645 BLAKE2B 88fed3d48f50c50276746dd2b69740482c95c83df13312e081ae4066351454f0a3afaad2f146c629ee39dd34708dd105941e2bc374146a6e9806631227372105 SHA512 85418189962611724488ea61f1b123c55c2f5ab9dd50d028c7ed1ed2965ff23e2679d514e863ac16b60a3c7c6b4fbd05e7c7ff398415e0435d72c96363b95188
diff --git a/dev-util/spirv-tools/files/spirv-tools-1.3.211-cmake-librt.patch b/dev-util/spirv-tools/files/spirv-tools-1.3.211-cmake-librt.patch
deleted file mode 100644
index 48afd5a736f1..000000000000
--- a/dev-util/spirv-tools/files/spirv-tools-1.3.211-cmake-librt.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-https://github.com/KhronosGroup/SPIRV-Tools/commit/cb96abbf7affd986016f17dd09f9f971138a922b
-
-From: Chad Versace <chad@kiwitree.net>
-Date: Thu, 14 Apr 2022 06:04:12 -0700
-Subject: [PATCH] Fix CMake for librt (#4773)
-
-In the installed file
-/usr/lib64/cmake/SPIRV-Tools/SPIRV-ToolsTarget.cmake, occurences of
-librt in the INTERFACE_LINK_LIBRARIES property are incorrect. The
-property contains the absolute path to librt. In most situations, this
-produces no problem. But when building in a sysroot, which is commonly
-done when cross-compiling, the absolute path breaks dependent projects.
-
-For example, when building spirv-tools using the Chrome OS SDK, and
-targeting the board 'volteer', where the build sysroot is
-'/build/volteer', the file includes this line
- INTERFACE_LINK_LIBRARIES "/build/volteer/usr/lib64/librt.so"
-when it should instead say
- INTERFACE_LINK_LIBRARIES "rt"
-
-The CMake documentation agrees [1]:
- Note that it is not advisable to populate the
- INTERFACE_LINK_LIBRARIES of a target with absolute paths to
- dependencies. That would hard-code into installed packages the
- library file paths for dependencies as found on the machine the
- package was made on.
-
-[1] https://cmake.org/cmake/help/latest/prop_tgt/INTERFACE_LINK_LIBRARIES.html
---- a/source/CMakeLists.txt
-+++ b/source/CMakeLists.txt
-@@ -407,7 +407,7 @@ if("${CMAKE_SYSTEM_NAME}" STREQUAL "Linux")
- find_library(LIBRT rt)
- if(LIBRT)
- foreach(target ${SPIRV_TOOLS_TARGETS})
-- target_link_libraries(${target} ${LIBRT})
-+ target_link_libraries(${target} rt)
- endforeach()
- endif()
- endif()
-
diff --git a/dev-util/spirv-tools/spirv-tools-1.3.211-r1.ebuild b/dev-util/spirv-tools/spirv-tools-1.3.211-r1.ebuild
deleted file mode 100644
index 246a6fc6ad67..000000000000
--- a/dev-util/spirv-tools/spirv-tools-1.3.211-r1.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-MY_PN=SPIRV-Tools
-CMAKE_ECLASS="cmake"
-PYTHON_COMPAT=( python3_{8..10} )
-PYTHON_REQ_USE="xml(+)"
-inherit cmake-multilib python-any-r1
-
-if [[ ${PV} == *9999* ]]; then
- EGIT_REPO_URI="https://github.com/KhronosGroup/${MY_PN}.git"
- inherit git-r3
-else
- EGIT_COMMIT="sdk-${PV}.0"
- SRC_URI="https://github.com/KhronosGroup/${MY_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="amd64 arm arm64 ~loong ppc ppc64 ~riscv x86"
- S="${WORKDIR}"/${MY_PN}-${EGIT_COMMIT}
-fi
-
-DESCRIPTION="Provides an API and commands for processing SPIR-V modules"
-HOMEPAGE="https://github.com/KhronosGroup/SPIRV-Tools"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-# Tests fail upon finding symbols that do not match a regular expression
-# in the generated library. Easily hit with non-standard compiler flags
-RESTRICT="test"
-COMMON_DEPEND="~dev-util/spirv-headers-${PV}"
-DEPEND="${COMMON_DEPEND}"
-RDEPEND=""
-BDEPEND="${PYTHON_DEPS}
- ${COMMON_DEPEND}"
-
-PATCHES=(
- "${FILESDIR}"/${P}-cmake-librt.patch
-)
-
-multilib_src_configure() {
- local mycmakeargs=(
- "-DSPIRV-Headers_SOURCE_DIR=${ESYSROOT}/usr/"
- "-DSPIRV_WERROR=OFF"
- "-DSPIRV_TOOLS_BUILD_STATIC=OFF"
- "-DBUILD_SHARED_LIBS=ON"
- )
-
- cmake_src_configure
-}