summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2020-12-06 13:07:12 -0500
committerMatt Turner <mattst88@gentoo.org>2020-12-06 13:33:07 -0500
commit6b65f0aeb83969edc646cbf3e225f35804263a7a (patch)
tree7c994b3ec746046f71c716341c6f58b7d9ac7eda /dev-util/sysprof-capture
parentRevert "dev-python/fsspec: bump to 0.8.4" (diff)
downloadgentoo-6b65f0aeb83969edc646cbf3e225f35804263a7a.tar.gz
gentoo-6b65f0aeb83969edc646cbf3e225f35804263a7a.tar.bz2
gentoo-6b65f0aeb83969edc646cbf3e225f35804263a7a.zip
dev-util/sysprof-capture: Add multilib support
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-util/sysprof-capture')
-rw-r--r--dev-util/sysprof-capture/sysprof-capture-3.36.0-r1.ebuild16
1 files changed, 14 insertions, 2 deletions
diff --git a/dev-util/sysprof-capture/sysprof-capture-3.36.0-r1.ebuild b/dev-util/sysprof-capture/sysprof-capture-3.36.0-r1.ebuild
index f5767d87f270..9eade9326177 100644
--- a/dev-util/sysprof-capture/sysprof-capture-3.36.0-r1.ebuild
+++ b/dev-util/sysprof-capture/sysprof-capture-3.36.0-r1.ebuild
@@ -4,7 +4,7 @@
EAPI=7
GNOME_ORG_MODULE="sysprof"
-inherit gnome.org meson systemd
+inherit gnome.org meson multilib-minimal systemd
DESCRIPTION="Static library for sysprof capture data generation"
HOMEPAGE="http://sysprof.com/"
@@ -23,7 +23,7 @@ BDEPEND="
virtual/pkgconfig
"
-src_configure() {
+multilib_src_configure() {
local emesonargs=(
-Denable_gtk=false
-Dlibsysprof=false
@@ -35,3 +35,15 @@ src_configure() {
)
meson_src_configure
}
+
+multilib_src_compile() {
+ meson_src_compile
+}
+
+multilib_src_test() {
+ meson_src_test
+}
+
+multilib_src_install() {
+ meson_src_install
+}