summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-06-10 10:10:05 +0100
committerSam James <sam@gentoo.org>2023-06-10 10:11:38 +0100
commitf88543ffef4bbaa86fb8323361c710b20e1e02da (patch)
tree35465eb70f1e742e0be4d0ed624822f49cf0e112 /dev-util/trace-cmd
parentdev-libs/libtracefs: add 1.7.0 (diff)
downloadgentoo-f88543ffef4bbaa86fb8323361c710b20e1e02da.tar.gz
gentoo-f88543ffef4bbaa86fb8323361c710b20e1e02da.tar.bz2
gentoo-f88543ffef4bbaa86fb8323361c710b20e1e02da.zip
dev-util/trace-cmd: add 3.2
Notes: * udis86 isn't wired up to meson at all * audit/zstd/zlib lack meson options for now. Previously, the situation was somewhat automagic, so this isn't a huge loss for now, but we should upstream some build options for these. They were also all default-on before. * python is now single target as it's much cleaner. Once we have options for doc+tests, we can revisit. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util/trace-cmd')
-rw-r--r--dev-util/trace-cmd/Manifest1
-rw-r--r--dev-util/trace-cmd/trace-cmd-3.2.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/dev-util/trace-cmd/Manifest b/dev-util/trace-cmd/Manifest
index 8dc49600418a..3b706f79c2a6 100644
--- a/dev-util/trace-cmd/Manifest
+++ b/dev-util/trace-cmd/Manifest
@@ -1,3 +1,4 @@
DIST trace-cmd-v3.1.4.tar.gz 328452 BLAKE2B 6d3c964d1ba585213b75834b1037449464e5d54e5f49ed5b532cc599f6b960b79d0f0327a6af38e38b3471b54316810d9f05ef6cc7a3a4e39ee7eec9864e5ef9 SHA512 93ad775c1767d2a02b72386a29867c3bc141171403c152c0c4cb907da16b5ae69100924279d9529083449c1774c97c35d5b4790b188bcd4930cfa69076cef0b8
DIST trace-cmd-v3.1.5.tar.gz 328689 BLAKE2B ae77b418505c545ef2b701c484cec944b6d8b9e7b0df9ea0a6475b099d59997a426a4c3f69fc2cfdaaaa4280f5fc53b18caf7a39011cd980fa331122f59feb13 SHA512 7262e69a990986975f0ee9287b16afc48f4f481fcb54ce64ca51dbba2e4c8cbb3c7c7d3d888aba10f3b12ac6b1cf9e612dd98982dc8d48ea221d231e3d16ac4d
DIST trace-cmd-v3.1.6.tar.gz 329041 BLAKE2B 0f5adace645f8598b11c2f4db4c0f6081fbb60bd6f27bf5b2d59d2ab5279a3f4ed065af924ea7204df206295408167e9a21924f09254d7d4daa8f07c53f77967 SHA512 2504863556a86759173f7114f5ab9a1d5641cefdd2bc9af64d8e5232d175e9c946fbb9dcec00d91b903e74b0e1bc52332877ddc9b705d6cfe2af9cb39797a446
+DIST trace-cmd-v3.2.tar.gz 342848 BLAKE2B d82309b72d00ae1b757039c7a358e7703c9e74527112baa05eb44f971067b1189b7833621766fdf8affc812b84b7bcfd071b2946495197d81a8ed8ff7240779e SHA512 6a8474e619b32ccf60217eba1ce472bdf6e77f6aff118b579f329b49eaf1b20c9a7802b539876be7c782f33dc78587cc510c7b4bf12af5707bfa2813e59ae442
diff --git a/dev-util/trace-cmd/trace-cmd-3.2.ebuild b/dev-util/trace-cmd/trace-cmd-3.2.ebuild
new file mode 100644
index 000000000000..0faa6c63b891
--- /dev/null
+++ b/dev-util/trace-cmd/trace-cmd-3.2.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_OPTIONAL=1
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit linux-info meson python-single-r1
+
+DESCRIPTION="User-space front-end for Ftrace"
+HOMEPAGE="https://git.kernel.org/pub/scm/utils/trace-cmd/trace-cmd.git"
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://git.kernel.org/pub/scm/utils/trace-cmd/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://git.kernel.org/pub/scm/utils/trace-cmd/trace-cmd.git/snapshot/${PN}-v${PV}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+ S="${WORKDIR}/${PN}-v${PV}"
+fi
+
+LICENSE="GPL-2+ LGPL-2.1+"
+SLOT="0/${PV}"
+IUSE="python test"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+# Tests segfault for now?
+RESTRICT="!test? ( test ) test"
+
+RDEPEND="
+ >=app-arch/zstd-1.4
+ !<dev-libs/libtracefs-1.6.1
+ >=dev-libs/libtracefs-1.6.1-r1
+ >=dev-libs/libtraceevent-1.6.3
+ sys-libs/zlib
+ sys-process/audit
+ python? ( ${PYTHON_DEPS} )
+"
+DEPEND="
+ ${RDEPEND}
+ sys-kernel/linux-headers
+ test? ( dev-util/cunit )
+"
+BDEPEND="
+ app-text/asciidoc
+ dev-util/source-highlight
+ virtual/pkgconfig
+ python? ( dev-lang/swig )
+"
+
+pkg_setup() {
+ local CONFIG_CHECK="
+ ~TRACING
+ ~FTRACE
+ ~BLK_DEV_IO_TRACE"
+
+ linux-info_pkg_setup
+
+ # TODO: Once we have options for doc+tests, we can revisit Python being
+ # single-impl.
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dasciidoctor=false
+ $(meson_use python)
+ )
+
+ # TODO: udis86 isn't wired up to meson at all
+ # TODO: get docs & tests optional upstream
+ # TODO: audit/zstd/zlib lack meson options for now. Previously, the situation
+ # was somewhat automagic, so this isn't a huge loss for now, but we should
+ # upstream some build options for these.
+ meson_src_configure
+}