summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2024-01-03 18:52:15 +0100
committerConrad Kostecki <conikost@gentoo.org>2024-01-07 01:19:31 +0100
commit76dc067e8a572b2f32f40683a4a166514360b775 (patch)
tree1574dc1154f8bd8618471074798bc8675e0449ff /dev-util/treecc
parentnet-analyzer/rrdtool: remove unused patch (diff)
downloadgentoo-76dc067e8a572b2f32f40683a4a166514360b775.tar.gz
gentoo-76dc067e8a572b2f32f40683a4a166514360b775.tar.bz2
gentoo-76dc067e8a572b2f32f40683a4a166514360b775.zip
dev-util/treecc: EAPI8 bump, fix calling ar directly, bug #724244
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Closes: https://bugs.gentoo.org/724244 Closes: https://github.com/gentoo/gentoo/pull/34621 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-util/treecc')
-rw-r--r--dev-util/treecc/treecc-0.3.10-r2.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-util/treecc/treecc-0.3.10-r2.ebuild b/dev-util/treecc/treecc-0.3.10-r2.ebuild
new file mode 100644
index 000000000000..faf9e7ab98ef
--- /dev/null
+++ b/dev-util/treecc/treecc-0.3.10-r2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Compiler-compiler tool for aspect-oriented programming"
+HOMEPAGE="https://www.gnu.org/software/dotgnu/"
+SRC_URI="https://download.savannah.gnu.org/releases/dotgnu-pnet/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="doc examples"
+
+DEPEND="doc? ( app-text/texi2html )"
+
+src_compile() {
+ emake AR="$(tc-getAR)"
+
+ if use doc; then
+ [[ -f "${S}"/doc/treecc.texi ]] || die "treecc.texi was not generated"
+ cd "${S}"/doc || die
+ texi2html -split_chapter "${S}"/doc/treecc.texi \
+ || die "texi2html failed"
+ cd "${S}" || die
+ fi
+}
+
+src_install() {
+ default
+
+ if use examples; then
+ docinto examples
+ dodoc examples/README
+ dodoc examples/{expr_c.tc,gram_c.y,scan_c.l}
+ fi
+
+ if use doc; then
+ dodoc doc/*.{txt,html}
+ docinto html
+ dodoc -r doc/treecc/*.html
+ fi
+}