summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2021-06-16 23:55:24 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2021-06-16 23:55:49 +0100
commit24bd40b29cd3f3b9249f945638fb483d93a4fb51 (patch)
tree08c8ef2e505cedb6a495198b0d481ef9816d2471 /dev-util/unifdef
parentprofiles.desc: add soft-float 20.0 riscv profiles (diff)
downloadgentoo-24bd40b29cd3f3b9249f945638fb483d93a4fb51.tar.gz
gentoo-24bd40b29cd3f3b9249f945638fb483d93a4fb51.tar.bz2
gentoo-24bd40b29cd3f3b9249f945638fb483d93a4fb51.zip
dev-util/unifdef: tweak tests for non-en locale and missing 'cc'
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-util/unifdef')
-rw-r--r--dev-util/unifdef/files/unifdef-2.12-tests.patch24
-rw-r--r--dev-util/unifdef/unifdef-2.12.ebuild2
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-util/unifdef/files/unifdef-2.12-tests.patch b/dev-util/unifdef/files/unifdef-2.12-tests.patch
new file mode 100644
index 000000000000..2f7d151250c2
--- /dev/null
+++ b/dev-util/unifdef/files/unifdef-2.12-tests.patch
@@ -0,0 +1,24 @@
+https://github.com/fanf2/unifdef/pull/13
+
+--- a/tests/multi-generic-sh
++++ b/tests/multi-generic-sh
+@@ -9,7 +9,7 @@ unifdef -M~ $opts $mfiles
+ e=$?
+ for f in $mfiles
+ do
+- diff -u $f~ $f | sed '/^[+-]\{3\} /s/ .*//'
++ LANG=C diff -u $f~ $f | sed '/^[+-]\{3\} /s/ .*//'
+ rm -f $f~ $f
+ done
+ exit $e
+--- a/unifdefall.sh
++++ b/unifdefall.sh
+@@ -48,7 +48,7 @@ export LC_ALL=C
+ # list of all controlling macros; assume these are undefined
+ "$unifdef" $debug -s "$@" | sort -u | sed 's/^/#undef /' >"$tmp/undefs"
+ # list of all macro definitions
+-cc -E -dM "$@" | sort >"$tmp/defs"
++${CC-cc} -E -dM "$@" | sort >"$tmp/defs"
+
+ case $debug in
+ -d) cat "$tmp/undefs" "$tmp/defs" 1>&2
diff --git a/dev-util/unifdef/unifdef-2.12.ebuild b/dev-util/unifdef/unifdef-2.12.ebuild
index cf3ba7f64167..d936e5d6a08b 100644
--- a/dev-util/unifdef/unifdef-2.12.ebuild
+++ b/dev-util/unifdef/unifdef-2.12.ebuild
@@ -13,6 +13,8 @@ LICENSE="BSD"
SLOT="0"
KEYWORDS="~alpha amd64 arm ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux"
+PATCHES=("${FILESDIR}"/${P}-tests.patch)
+
DOCS=( README )
src_prepare() {