summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2019-12-10 19:04:50 -0800
committerPatrick McLean <chutzpah@gentoo.org>2019-12-10 19:04:50 -0800
commit2df95683c2e623f72d506be6abbef7e3eaf3c2cd (patch)
tree8141957c1f8bd754de84ba8829fae9ed33b15a13 /dev-util
parentdev-util/bcc-0.12.0: Version bump (diff)
downloadgentoo-2df95683c2e623f72d506be6abbef7e3eaf3c2cd.tar.gz
gentoo-2df95683c2e623f72d506be6abbef7e3eaf3c2cd.tar.bz2
gentoo-2df95683c2e623f72d506be6abbef7e3eaf3c2cd.zip
dev-util/gcovr-4.2: Version bump (bug #702332)
Tried to remove RESTRICT="test", but tests rely on gcc-5.8 and break with other versions. Closes: https://bugs.gentoo.org/702332 Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/gcovr/Manifest1
-rw-r--r--dev-util/gcovr/gcovr-4.2.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-util/gcovr/Manifest b/dev-util/gcovr/Manifest
index 3b1af4f2f1c9..ba3c6c7501af 100644
--- a/dev-util/gcovr/Manifest
+++ b/dev-util/gcovr/Manifest
@@ -1,2 +1,3 @@
DIST gcovr-3.3.tar.gz 323226 BLAKE2B fe3d6ab4d24032f57ee17c3fc44b10e0b177aad01b072306a99abc7dbfee07b5f14ef34412d36938302bc279dffb2a25502981ba952339c1b4e896762defabb0 SHA512 e5046bc4e38c99691c3bcc58abdfbbe965c46d02c8c50dbf135bd5108bd9bba1fa450ab0b5e23157a178f7c1303ec9c285470e9be1a14274528e5d7051013a08
DIST gcovr-4.1.tar.gz 193692 BLAKE2B 5536ecbf0636a3a75083d53e2dc239a48e6df740a037954a2aa2e837e764c0530c73fe32c66078efa4c3a6652f907ec15505c8efbac8a1d861031d34b05f4c74 SHA512 aab2a98421557ffe846f644725e5c6cee65afb0c22ca86ce8713516810bc91bd32caf4c5c18e2628f8f4444de6665478a6001cfce3841a8c394fc0b4309d83fb
+DIST gcovr-4.2.tar.gz 222847 BLAKE2B 44864c89b58b526c5afc293168c8af2c9082a99e92f2315485f10430fa5ff959046d189c018e0fa121ff4e9fc3685c13b737c112856c841966052d5fd6c9169a SHA512 bf9e22a58b8390eca391dc8f6ba58c4ca0765e66f18ac6f8d8f80609411df2bab74a846eb179a1aded81b7774fa8a8121bb2d586556aeaf43fd729205b0d0c72
diff --git a/dev-util/gcovr/gcovr-4.2.ebuild b/dev-util/gcovr/gcovr-4.2.ebuild
new file mode 100644
index 000000000000..5b264d4b384b
--- /dev/null
+++ b/dev-util/gcovr/gcovr-4.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} )
+DISTUTILS_IN_SOURCE_BUILD=1
+
+inherit distutils-r1
+
+DESCRIPTION="A Python script for summarizing gcov data"
+HOMEPAGE="https://github.com/gcovr/gcovr"
+SRC_URI="https://github.com/gcovr/gcovr/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+"
+BDEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/PyUtilib[${PYTHON_USEDEP}]
+ virtual/python-typing[${PYTHON_USEDEP}]
+ )
+"
+
+# tests fail on gcc newer than 5.8
+# https://github.com/gcovr/gcovr/issues/206
+RESTRICT="test"
+
+distutils_enable_tests pytest
+
+python_test() {
+ distutils_install_for_testing
+
+ local -x PATH="${TEST_DIR}/scripts:${PATH}" \
+ PYTHONPATH="${TEST_DIR}/lib"
+
+ pytest -vv gcovr || die "Tests fail with ${EPYTHON}"
+}