summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-06-12 06:28:30 +0100
committerSam James <sam@gentoo.org>2022-06-12 06:28:30 +0100
commit5b3a94a94085b43c5d67c5914a9006131d068faa (patch)
tree9a64fc465c346d298ece0c9d95a999236e0e61fc /dev-util
parentdev-libs/tlsh: add github upstream metadata (diff)
downloadgentoo-5b3a94a94085b43c5d67c5914a9006131d068faa.tar.gz
gentoo-5b3a94a94085b43c5d67c5914a9006131d068faa.tar.bz2
gentoo-5b3a94a94085b43c5d67c5914a9006131d068faa.zip
dev-util/pkgdev: backport man page fix
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/pkgdev/files/pkgdev-0.2.1-fix-signoff-example.patch25
-rw-r--r--dev-util/pkgdev/pkgdev-0.2.1-r1.ebuild68
2 files changed, 93 insertions, 0 deletions
diff --git a/dev-util/pkgdev/files/pkgdev-0.2.1-fix-signoff-example.patch b/dev-util/pkgdev/files/pkgdev-0.2.1-fix-signoff-example.patch
new file mode 100644
index 000000000000..9fddf8a768fb
--- /dev/null
+++ b/dev-util/pkgdev/files/pkgdev-0.2.1-fix-signoff-example.patch
@@ -0,0 +1,25 @@
+https://github.com/pkgcore/pkgdev/commit/b780cf967804cb532421ef7cced5f1964224d8dd
+
+From: Arthur Zamarin <arthurzam@gentoo.org>
+Date: Mon, 23 May 2022 22:07:43 +0300
+Subject: [PATCH] docs: fix signoff example
+
+Fixes: https://github.com/pkgcore/pkgdev/issues/72
+Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
+--- a/doc/man/config.rst
++++ b/doc/man/config.rst
+@@ -34,10 +34,10 @@ related values. To find all possible configuration options, run:
+ push.ask = true
+
+ - Add `Signed-off-by` consenting to the `Certificate of Origin <https://www.gentoo.org/glep/glep-0076.html#certificate-of-origin>`_
+- to all commits for the 'gentoo' repository::
++ to all commits::
+
+- [gentoo]
+- push.signoff = true
++ [DEFAULT]
++ commit.signoff = true
+
+ - When committing, stage all files in current working directory (note that this
+ option doesn't expect value, therefore no value is defined post equal sign)::
+
diff --git a/dev-util/pkgdev/pkgdev-0.2.1-r1.ebuild b/dev-util/pkgdev/pkgdev-0.2.1-r1.ebuild
new file mode 100644
index 000000000000..1b214da9f039
--- /dev/null
+++ b/dev-util/pkgdev/pkgdev-0.2.1-r1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_IN_SOURCE_BUILD=1
+inherit distutils-r1
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/pkgcore/pkgdev.git"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86 ~x64-macos"
+fi
+
+DESCRIPTION="Collection of tools for Gentoo development"
+HOMEPAGE="https://github.com/pkgcore/pkgdev"
+
+LICENSE="BSD MIT"
+SLOT="0"
+
+if [[ ${PV} == *9999 ]] ; then
+ # https://github.com/pkgcore/pkgdev/blob/main/requirements/dev.txt
+ RDEPEND="
+ ~dev-python/snakeoil-9999[${PYTHON_USEDEP}]
+ ~dev-util/pkgcheck-9999[${PYTHON_USEDEP}]
+ ~sys-apps/pkgcore-9999[${PYTHON_USEDEP}]
+ "
+else
+ # https://github.com/pkgcore/pkgdev/blob/main/requirements/install.txt
+ RDEPEND="
+ >=dev-python/snakeoil-0.9.6[${PYTHON_USEDEP}]
+ >=dev-util/pkgcheck-0.10.0[${PYTHON_USEDEP}]
+ >=sys-apps/pkgcore-0.12.0[${PYTHON_USEDEP}]
+ "
+fi
+
+# Uses pytest but we want to use the setup.py runner to get generated modules
+BDEPEND+="test? ( dev-python/pytest )"
+RDEPEND+="dev-vcs/git"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-fix-signoff-example.patch
+)
+
+distutils_enable_sphinx doc
+distutils_enable_tests setup.py
+
+python_install_all() {
+ # We'll generate man pages ourselves
+ # Revisit when a release is made
+ # to pregenerate them, making USE=doc
+ # for generating the real HTML docs only.
+ if use doc ; then
+ cd doc || die
+ emake man
+ doman _build/man/*
+ fi
+
+ cd .. || die
+
+ # HTML pages only
+ sphinx_compile_all
+
+ distutils-r1_python_install_all
+}