summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2023-07-10 11:33:40 -0400
committerMatt Turner <mattst88@gentoo.org>2023-07-10 11:34:03 -0400
commit6020fc656e53f467c2d548a6550f835e07780b1f (patch)
tree6c1ef81d3d27b69ebfe82f551d08b589c45bba25 /dev-util
parentwww-apps/readarr: drop 0.2.1.1915 (diff)
downloadgentoo-6020fc656e53f467c2d548a6550f835e07780b1f.tar.gz
gentoo-6020fc656e53f467c2d548a6550f835e07780b1f.tar.bz2
gentoo-6020fc656e53f467c2d548a6550f835e07780b1f.zip
dev-util/perf: Filter LTO flags
Bug: https://bugs.gentoo.org/858449 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/perf/perf-6.3-r1.ebuild4
-rw-r--r--dev-util/perf/perf-6.3.ebuild4
-rw-r--r--dev-util/perf/perf-6.4-r1.ebuild4
3 files changed, 9 insertions, 3 deletions
diff --git a/dev-util/perf/perf-6.3-r1.ebuild b/dev-util/perf/perf-6.3-r1.ebuild
index eb28c4419c9b..d519238f14e1 100644
--- a/dev-util/perf/perf-6.3-r1.ebuild
+++ b/dev-util/perf/perf-6.3-r1.ebuild
@@ -4,7 +4,7 @@
EAPI=8
PYTHON_COMPAT=( python3_{10..12} )
-inherit bash-completion-r1 estack llvm toolchain-funcs python-r1 linux-info
+inherit bash-completion-r1 estack flag-o-matic llvm toolchain-funcs python-r1 linux-info
DESCRIPTION="Userland tools for Linux Performance Counters"
HOMEPAGE="https://perf.wiki.kernel.org/"
@@ -231,6 +231,8 @@ perf_make() {
}
src_compile() {
+ filter-lto
+
# test-clang.bin not build with g++
if use clang; then
make -C "${S_K}/tools/build/feature" V=1 CXX=${CHOST}-clang++ test-clang.bin || die
diff --git a/dev-util/perf/perf-6.3.ebuild b/dev-util/perf/perf-6.3.ebuild
index 31bad3f7e7fe..8f0ac9a76ce4 100644
--- a/dev-util/perf/perf-6.3.ebuild
+++ b/dev-util/perf/perf-6.3.ebuild
@@ -4,7 +4,7 @@
EAPI=7
PYTHON_COMPAT=( python3_{9..11} )
-inherit bash-completion-r1 estack llvm toolchain-funcs python-r1 linux-info
+inherit bash-completion-r1 estack flag-o-matic llvm toolchain-funcs python-r1 linux-info
DESCRIPTION="Userland tools for Linux Performance Counters"
HOMEPAGE="https://perf.wiki.kernel.org/"
@@ -224,6 +224,8 @@ perf_make() {
}
src_compile() {
+ filter-lto
+
# test-clang.bin not build with g++
if use clang; then
make -C "${S_K}/tools/build/feature" V=1 CXX=${CHOST}-clang++ test-clang.bin || die
diff --git a/dev-util/perf/perf-6.4-r1.ebuild b/dev-util/perf/perf-6.4-r1.ebuild
index 83118f390754..c341b8367f60 100644
--- a/dev-util/perf/perf-6.4-r1.ebuild
+++ b/dev-util/perf/perf-6.4-r1.ebuild
@@ -4,7 +4,7 @@
EAPI=8
PYTHON_COMPAT=( python3_{10..12} )
-inherit bash-completion-r1 estack linux-info llvm toolchain-funcs python-r1
+inherit bash-completion-r1 estack flag-o-matic linux-info llvm toolchain-funcs python-r1
DESCRIPTION="Userland tools for Linux Performance Counters"
HOMEPAGE="https://perf.wiki.kernel.org/"
@@ -266,6 +266,8 @@ perf_make() {
}
src_compile() {
+ filter-lto
+
# test-clang.bin not build with g++
if use clang; then
make -C "${S_K}/tools/build/feature" V=1 CXX=${CHOST}-clang++ test-clang.bin || die