summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWANG Xuerui <xen0n@gentoo.org>2023-01-24 20:21:30 +0800
committerSam James <sam@gentoo.org>2023-01-25 06:10:33 +0000
commit673d98d340be8a49f6c7360d8f5b9d6e0cfb100b (patch)
treee693b62664f913829df20935777f63dfee050972 /dev-util
parentnet-wireless/gr-osmosdr: append main repository HOMEPAGE (diff)
downloadgentoo-673d98d340be8a49f6c7360d8f5b9d6e0cfb100b.tar.gz
gentoo-673d98d340be8a49f6c7360d8f5b9d6e0cfb100b.tar.bz2
gentoo-673d98d340be8a49f6c7360d8f5b9d6e0cfb100b.zip
dev-util/gyp: fix faulty sed usage
It currently mis-replaces `from six.moves import collections_abc`, giving `from ... import collections.abc_abc` which is invalid syntax. Signed-off-by: WANG Xuerui <xen0n@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/29241 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/gyp/gyp-99999999999999.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/dev-util/gyp/gyp-99999999999999.ebuild b/dev-util/gyp/gyp-99999999999999.ebuild
index cc8257c39716..22b7cac6dc60 100644
--- a/dev-util/gyp/gyp-99999999999999.ebuild
+++ b/dev-util/gyp/gyp-99999999999999.ebuild
@@ -35,12 +35,12 @@ python_prepare_all() {
sed -e "s/' Linux %s' % ' '\.join(platform.linux_distribution())/' Linux'/" -i gyptest.py || die
sed \
- -e "s/import collections/import collections.abc/" \
+ -e "s/^import collections/import collections.abc/" \
-e "s/collections\.MutableSet/collections.abc.MutableSet/" \
-i pylib/gyp/common.py || die
sed -e "s/the_dict_key is 'variables'/the_dict_key == 'variables'/" -i pylib/gyp/input.py || die
sed \
- -e "s/import collections/import collections.abc/" \
+ -e "s/^import collections/import collections.abc/" \
-e "s/collections\.Iterable/collections.abc.Iterable/" \
-i pylib/gyp/msvs_emulation.py || die
sed \