summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2024-02-24 19:32:37 -0500
committerMatt Turner <mattst88@gentoo.org>2024-02-24 19:33:00 -0500
commit9044c33b339a9523761166cc9994cccb9d2df697 (patch)
tree95921caafd39e82bc36239bb154ddd7a52f446d0 /dev-util
parentdev-libs/jemalloc: Take ownership (diff)
downloadgentoo-9044c33b339a9523761166cc9994cccb9d2df697.tar.gz
gentoo-9044c33b339a9523761166cc9994cccb9d2df697.tar.bz2
gentoo-9044c33b339a9523761166cc9994cccb9d2df697.zip
dev-util/spirv-llvm-translator: Add patch to fix test failure
Bug: https://bugs.gentoo.org/920053 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/spirv-llvm-translator/files/spirv-llvm-translator-17.0.0-do-not-rely-on-version-of-compiler-being-VER.0.0-219.patch26
-rw-r--r--dev-util/spirv-llvm-translator/spirv-llvm-translator-17.0.0-r2.ebuild5
2 files changed, 30 insertions, 1 deletions
diff --git a/dev-util/spirv-llvm-translator/files/spirv-llvm-translator-17.0.0-do-not-rely-on-version-of-compiler-being-VER.0.0-219.patch b/dev-util/spirv-llvm-translator/files/spirv-llvm-translator-17.0.0-do-not-rely-on-version-of-compiler-being-VER.0.0-219.patch
new file mode 100644
index 000000000000..e2a575600c44
--- /dev/null
+++ b/dev-util/spirv-llvm-translator/files/spirv-llvm-translator-17.0.0-do-not-rely-on-version-of-compiler-being-VER.0.0-219.patch
@@ -0,0 +1,26 @@
+From 587443c9e9094f37ac4e185fb4f889913c6992a9 Mon Sep 17 00:00:00 2001
+From: Dmitry Sidorov <dmitry.sidorov@intel.com>
+Date: Thu, 26 Oct 2023 04:36:07 -0700
+Subject: [PATCH] do not rely on version of compiler being $VER.0.0 (#2194)
+
+Co-authored-by: Stanley Gambarin <stanley.gambarin@intel.com>
+---
+ test/DebugInfo/NonSemantic/DebugFunction.cl | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/test/DebugInfo/NonSemantic/DebugFunction.cl b/test/DebugInfo/NonSemantic/DebugFunction.cl
+index 43294916..f84b303a 100644
+--- a/test/DebugInfo/NonSemantic/DebugFunction.cl
++++ b/test/DebugInfo/NonSemantic/DebugFunction.cl
+@@ -25,7 +25,7 @@ void kernel k() {
+ // CHECK-SPIRV-DAG: String [[foo:[0-9]+]] "foo"
+ // CHECK-SPIRV-DAG: String [[#EmptyStr:]] ""
+ // CHECK-SPIRV-DAG: String [[k:[0-9]+]] "k"
+-// CHECK-SPIRV-DAG: String [[#CV:]] "{{.*}}clang version [[#]].0.0
++// CHECK-SPIRV-DAG: String [[#CV:]] "{{.*}}clang version [[#]].[[#]].[[#]]
+ // CHECK-SPIRV: [[#CU:]] [[#]] DebugCompilationUnit
+ // CHECK-SPIRV: [[#FuncFoo:]] [[#]] DebugFunction [[foo]] {{.*}} [[#CU]]
+ // CHECK-SPIRV: [[#FuncK:]] [[#]] DebugFunction [[k]] {{.*}} [[#CU]]
+--
+2.43.0
+
diff --git a/dev-util/spirv-llvm-translator/spirv-llvm-translator-17.0.0-r2.ebuild b/dev-util/spirv-llvm-translator/spirv-llvm-translator-17.0.0-r2.ebuild
index 8805557f442f..d0887f26c351 100644
--- a/dev-util/spirv-llvm-translator/spirv-llvm-translator-17.0.0-r2.ebuild
+++ b/dev-util/spirv-llvm-translator/spirv-llvm-translator-17.0.0-r2.ebuild
@@ -35,7 +35,10 @@ BDEPEND="
)
"
-PATCHES=( "${FILESDIR}/${PN}-17.0.0-intel-capability.patch" )
+PATCHES=(
+ "${FILESDIR}"/${P}-intel-capability.patch
+ "${FILESDIR}"/${P}-do-not-rely-on-version-of-compiler-being-VER.0.0-219.patch
+)
src_prepare() {
append-flags -fPIC