summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonas Stein <jstein@gentoo.org>2024-04-08 23:22:24 +0200
committerJonas Stein <jstein@gentoo.org>2024-04-08 23:22:50 +0200
commitac32d6459f01c627264b8fdc5420b0be38fe5bf6 (patch)
treed195e224d663e343c82fecbe203f862b0421e133 /dev-util
parentnet-mail/mu: add 1.12.3 (diff)
downloadgentoo-ac32d6459f01c627264b8fdc5420b0be38fe5bf6.tar.gz
gentoo-ac32d6459f01c627264b8fdc5420b0be38fe5bf6.tar.bz2
gentoo-ac32d6459f01c627264b8fdc5420b0be38fe5bf6.zip
dev-util/reuse: add 3.0.2
Signed-off-by: Jonas Stein <jstein@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/reuse/Manifest1
-rw-r--r--dev-util/reuse/reuse-3.0.2.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-util/reuse/Manifest b/dev-util/reuse/Manifest
index 730e7d6ded68..3709263d0beb 100644
--- a/dev-util/reuse/Manifest
+++ b/dev-util/reuse/Manifest
@@ -1,2 +1,3 @@
DIST reuse-2.1.0.gh.tar.gz 260786 BLAKE2B 371c1167e10449ecdbaf0a93dbfa7d50c700daaf71394379a48d1baaae0b1be03728e79fd551da75a3743e06cae1a77e7445482222845d1356a6af3eb39bef46 SHA512 912d713b2c68029cc67a5fbebfca61d96165ae8ae9d927bbdd651cf2130104b297d5c0133f1a46442cba3ec84d00ba92c27414bff770d2250f5a2131c7ad4aef
DIST reuse-3.0.1.gh.tar.gz 305441 BLAKE2B e2f0cc4b4aea3e2b09e4ee395ec545a6cd683a083d05498b56401782439882853673bfb3d589ef6c4986cd86fcab64b9cc5ae40e5ddc7f36478582ca458fff81 SHA512 eb3aeb98b6fe127001702cf2a2c067e298fba071582206174a3647ccbf38263fa71dc6e56558926e4adce628c541035e4bce2afaa9fddfd89cbdb20cfe57aef5
+DIST reuse-3.0.2.gh.tar.gz 305529 BLAKE2B 96835aa6c47a951d7515236a632895e22ea93cad3602c4c37f45714ebe830b605315af479b7e5bbad764420ffc59997a163bbbe7a1b133bcd72f88af60b67c80 SHA512 cdf37980dddb116823fd0f0d47f6b6380e9da500cb3f33cf4fcfb75c367af7a7e3147848463f3d70c28dce72b8c0ad5d0b8284a69f7905050b0ba9ee7fff2f5c
diff --git a/dev-util/reuse/reuse-3.0.2.ebuild b/dev-util/reuse/reuse-3.0.2.ebuild
new file mode 100644
index 000000000000..bf0a250f90bb
--- /dev/null
+++ b/dev-util/reuse/reuse-3.0.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=poetry
+
+inherit distutils-r1
+
+DESCRIPTION="Manage license information according to the SPDX standard"
+HOMEPAGE="https://reuse.software/
+ https://github.com/fsfe/reuse-tool"
+MY_PN="${PN}-tool"
+SRC_URI="https://github.com/fsfe/${MY_PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="GPL-3+ CC-BY-SA-4.0 CC0-1.0 Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND=">=dev-python/binaryornot-0.4.4[${PYTHON_USEDEP}]
+ >=dev-python/boolean-py-3.8[${PYTHON_USEDEP}]
+ >=dev-python/jinja-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/license-expression-1.0[${PYTHON_USEDEP}]
+ >=dev-python/python-debian-0.1.48[${PYTHON_USEDEP}]"
+
+BDEPEND="sys-devel/gettext
+ test? (
+ dev-vcs/git
+ dev-vcs/mercurial
+ )"
+
+PATCHES=( "${FILESDIR}/reuse-2.1.0_docs.patch" )
+
+DOCS=( AUTHORS.rst CHANGELOG.md CODE_OF_CONDUCT.md CONTRIBUTING.md README.md )
+
+distutils_enable_tests pytest
+
+# dev-python/sphinx-autodoc-typehints will be dropped after 2.1.0
+distutils_enable_sphinx docs \
+ ">=dev-python/furo-2023.3.27" \
+ ">=dev-python/recommonmark-0.7.1" \
+ ">=dev-python/sphinxcontrib-apidoc-0.3.0" \
+ ">=dev-python/sphinx-autodoc-typehints-1.12.0"
+
+python_test() {
+ cd "${T}" || die
+ epytest "${S}"/tests
+}