summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2023-12-27 20:32:27 -0500
committerSam James <sam@gentoo.org>2023-12-28 02:18:23 +0000
commitc01810d7f0699fd978d78538429ee7618b21909c (patch)
tree934bf472cef15da7fa5cb8980e6198e16c74ccee /dev-util
parentdev-util/source-highlight: remove unneeded runtime dependency on ctags (diff)
downloadgentoo-c01810d7f0699fd978d78538429ee7618b21909c.tar.gz
gentoo-c01810d7f0699fd978d78538429ee7618b21909c.tar.bz2
gentoo-c01810d7f0699fd978d78538429ee7618b21909c.zip
dev-util/source-highlight: apply elibtoolize to old distributed libtool
This makes the build respect warning flags such as -Werror=odr. Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/source-highlight/source-highlight-3.1.9-r2.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/dev-util/source-highlight/source-highlight-3.1.9-r2.ebuild b/dev-util/source-highlight/source-highlight-3.1.9-r2.ebuild
index 1c663d28de8c..fb6cbdde1165 100644
--- a/dev-util/source-highlight/source-highlight-3.1.9-r2.ebuild
+++ b/dev-util/source-highlight/source-highlight-3.1.9-r2.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit bash-completion-r1 flag-o-matic optfeature
+inherit bash-completion-r1 flag-o-matic libtool optfeature
DESCRIPTION="Generate highlighted source code as an (x)html document"
HOMEPAGE="https://www.gnu.org/software/src-highlite/source-highlight.html"
@@ -23,6 +23,14 @@ PATCHES=(
"${FILESDIR}"/${PN}-3.1.9-test-clang-p2.patch
)
+src_prepare() {
+ default
+
+ # Although all unpatched libtools are probably broken, this one ignores LTO
+ # warning flags.
+ elibtoolize
+}
+
src_configure() {
# required as rev-dep of dev-libs/boost-1.62.0
# https://wiki.gentoo.org/wiki/Project:C%2B%2B/Maintaining_ABI