summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2020-06-07 12:53:16 -0500
committerWilliam Hubbs <williamh@gentoo.org>2020-06-07 12:59:47 -0500
commitffcf0ed0166a91e2e6f1bd5ea8ab7e39117ae38c (patch)
tree95977b010bb9ee8637ba0a5275a51d354280dc6e /dev-util
parentdev-haskell/opengl: update homepage link (diff)
downloadgentoo-ffcf0ed0166a91e2e6f1bd5ea8ab7e39117ae38c.tar.gz
gentoo-ffcf0ed0166a91e2e6f1bd5ea8ab7e39117ae38c.tar.bz2
gentoo-ffcf0ed0166a91e2e6f1bd5ea8ab7e39117ae38c.zip
dev-util/github-cli: drop patch and use "go run" for completions
The makefile uses "go run" to generate the man pages, so we really don't need to build a gen-docs binary. Also, switch to using "go run" to generate the shell completions. Once we allow cross compiling, we can use the first emake to compile gh for the target and run everything else on the host. Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/github-cli/github-cli-0.9.0-r1.ebuild23
1 files changed, 9 insertions, 14 deletions
diff --git a/dev-util/github-cli/github-cli-0.9.0-r1.ebuild b/dev-util/github-cli/github-cli-0.9.0-r1.ebuild
index 9da2da770a1f..a85b465b8d87 100644
--- a/dev-util/github-cli/github-cli-0.9.0-r1.ebuild
+++ b/dev-util/github-cli/github-cli-0.9.0-r1.ebuild
@@ -273,13 +273,6 @@ LICENSE="MIT Apache-2.0 BSD BSD-2 MPL-2.0"
SLOT="0"
RDEPEND=">=dev-vcs/git-1.7.3"
-BDEPEND=">=dev-lang/go-1.13"
-
-unset GOBIN GOPATH GOCODE
-
-PATCHES=(
- "${FILESDIR}/cli-0.9.0-manpage-build-gen-docs.patch"
-)
src_unpack() {
if [[ ${PV} == *9999 ]]; then
@@ -292,17 +285,19 @@ src_unpack() {
src_compile() {
[[ ${PV} == *9999 ]] || export GH_VERSION="v${PV}"
- # Golang LDFLAGS are not the same as GCC/Binutils LDFLAGS
+ # Go LDFLAGS are not the same as GCC/Binutils LDFLAGS
unset LDFLAGS
+ # Once we set up cross compiling, this line will need to be adjusted
+ # to compile for the target.
+ # Everything else in this function happens on the host.
+ emake
- emake bin/gh # default target
-
- einfo "Building manpage"
+ einfo "Building man pages"
emake manpages
- einfo "Building completion"
- bin/gh completion -s bash > gh.bash-completion || die
- bin/gh completion -s zsh > gh.zsh-completion || die
+ einfo "Building completions"
+ go run ./cmd/gh completion -s bash > gh.bash-completion || die
+ go run ./cmd/gh completion -s zsh > gh.zsh-completion || die
}
src_install() {