summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2016-04-09 09:54:41 +0200
committerFabian Groffen <grobian@gentoo.org>2016-04-09 09:57:49 +0200
commit4f4340f877b5bdfd5f35cdcc98696b591a434e95 (patch)
treea1cd85b55f319da812b7e6fb663f7edf942d3641 /dev-vcs/git/git-9999-r2.ebuild
parentapp-emulation/wine: Version bump to 1.9.6 and 1.9.7 (diff)
downloadgentoo-4f4340f877b5bdfd5f35cdcc98696b591a434e95.tar.gz
gentoo-4f4340f877b5bdfd5f35cdcc98696b591a434e95.tar.bz2
gentoo-4f4340f877b5bdfd5f35cdcc98696b591a434e95.zip
dev-vcs/git: respect CC/CFLAGS while building osxkeychain credential on Darwin
Package-Manager: portage-2.2.27
Diffstat (limited to 'dev-vcs/git/git-9999-r2.ebuild')
-rw-r--r--dev-vcs/git/git-9999-r2.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/dev-vcs/git/git-9999-r2.ebuild b/dev-vcs/git/git-9999-r2.ebuild
index 56b5b6bb100e..4de6ab76a7fe 100644
--- a/dev-vcs/git/git-9999-r2.ebuild
+++ b/dev-vcs/git/git-9999-r2.ebuild
@@ -330,8 +330,9 @@ src_compile() {
fi
if [[ ${CHOST} == *-darwin* ]]; then
- cd "${S}"/contrib/credential/osxkeychain || die "cd credential/osxkeychain"
- git_emake || die "emake credential-osxkeychain"
+ cd "${S}"/contrib/credential/osxkeychain || die
+ git_emake CC=$(tc-getCC) CFLAGS="${CFLAGS}" \
+ || die "emake credential-osxkeychain"
fi
cd "${S}"/Documentation