summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2023-01-25 14:46:40 -0600
committerWilliam Hubbs <williamh@gentoo.org>2023-01-25 14:47:54 -0600
commit9dbb4a50dce705855e472f510e2e2c1f9c940979 (patch)
tree5e17b1ce4cd1a87f40f62fe12848aef19f23cfcf /dev-vcs/python-gitlab
parentgui-wm/sway: stabilize 1.8-r1 for amd64, arm64, x86 (diff)
downloadgentoo-9dbb4a50dce705855e472f510e2e2c1f9c940979.tar.gz
gentoo-9dbb4a50dce705855e472f510e2e2c1f9c940979.tar.bz2
gentoo-9dbb4a50dce705855e472f510e2e2c1f9c940979.zip
dev-vcs/python-gitlab: drop 3.10.0
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'dev-vcs/python-gitlab')
-rw-r--r--dev-vcs/python-gitlab/Manifest1
-rw-r--r--dev-vcs/python-gitlab/python-gitlab-3.10.0.ebuild39
2 files changed, 0 insertions, 40 deletions
diff --git a/dev-vcs/python-gitlab/Manifest b/dev-vcs/python-gitlab/Manifest
index 65d19356ee97..6acc87f4d9ae 100644
--- a/dev-vcs/python-gitlab/Manifest
+++ b/dev-vcs/python-gitlab/Manifest
@@ -1,2 +1 @@
-DIST python-gitlab-3.10.0.tar.gz 254166 BLAKE2B 74b1a200e4ac1e99d5fc89b3906e8e623e3e7c210b0483e3947f24b882e61ce4ca9dafd43cfb047e4fa848c8970429ff0391db7c750d452db0ca4f5034bb772f SHA512 5dc0fbe826fe1a07833a8d443721e540b6b6e8c35cf100286b9a1a964f2f8b4faa34df2eff9888507c6ba1835857216a73084f860343a494eac9f1353a28f327
DIST python-gitlab-3.12.0.tar.gz 264005 BLAKE2B 64215b0c2950b1d238ff0e69e88de463ce2645d7c3911963e516b50874b49c4e822f8e27625fa33e6d27a703cc3bb3377151a9bc9c49b0b49ee7bc57db5dfd65 SHA512 76f55945a821553b4b477629dea674956459836df227e70817480b031559317ec97fef6c332d0dc42c4dba0d556ed1118e1cded8f116f4813bebe411db9e7a47
diff --git a/dev-vcs/python-gitlab/python-gitlab-3.10.0.ebuild b/dev-vcs/python-gitlab/python-gitlab-3.10.0.ebuild
deleted file mode 100644
index 2a48c10e476c..000000000000
--- a/dev-vcs/python-gitlab/python-gitlab-3.10.0.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9,10} )
-inherit distutils-r1
-
-DESCRIPTION="Python command line interface to gitlab API"
-HOMEPAGE="https://github.com/python-gitlab/python-gitlab/"
-
-if [[ ${PV} = *9999* ]]; then
- EGIT_REPO_URI="https://github.com/python-gitlab/python-gitlab"
- inherit git-r3
-else
- SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
- KEYWORDS="~amd64"
-fi
-
-LICENSE="LGPL-3"
-SLOT="0"
-
-BDEPEND="test? (
-dev-python/coverage[${PYTHON_USEDEP}]
->=dev-python/pytest-console-scripts-1.3.1[${PYTHON_USEDEP}]
-dev-python/pytest-cov[${PYTHON_USEDEP}]
->=dev-python/pyyaml-5.2[${PYTHON_USEDEP}]
- dev-python/responses[${PYTHON_USEDEP}]
- )"
-
-RDEPEND=">=dev-python/requests-2.28.1[${PYTHON_USEDEP}]
- >=dev-python/requests-toolbelt-0.10.0[${PYTHON_USEDEP}]"
-
-distutils_enable_tests pytest
-
-python_install_all() {
- distutils-r1_python_install_all
- dodoc -r *.rst docs
-}