summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-02-03 09:40:04 +0000
committerSam James <sam@gentoo.org>2022-02-03 09:40:08 +0000
commite134a2a691578ccfda625110518446405602e7a0 (patch)
treec9dbdc8e6be6bb8781e9e2c027e412064910d348 /dev-vcs/rcs
parentsys-apps/hwdata: add 0.356 (diff)
downloadgentoo-e134a2a691578ccfda625110518446405602e7a0.tar.gz
gentoo-e134a2a691578ccfda625110518446405602e7a0.tar.bz2
gentoo-e134a2a691578ccfda625110518446405602e7a0.zip
dev-vcs/rcs: add 5.10.1
Mainly lets us drop the upstream patches we backported. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-vcs/rcs')
-rw-r--r--dev-vcs/rcs/Manifest1
-rw-r--r--dev-vcs/rcs/rcs-5.10.1.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-vcs/rcs/Manifest b/dev-vcs/rcs/Manifest
index da8459ef7e57..9d7be564c5e0 100644
--- a/dev-vcs/rcs/Manifest
+++ b/dev-vcs/rcs/Manifest
@@ -1 +1,2 @@
DIST rcs-5.10.0.tar.xz 890872 BLAKE2B 32000df00c639cec90fb9128503b67957a23c82a08651953b57434c3f14ecea555155da933d5be801ad216aa27ccf496a7aae325cecf73f9bc121f3a3c659cba SHA512 d42bded1214f27dfcbe912bbabad8479555a02bc57000a62512d63ff0672de1ed23911cd15c9d1aa4b9a53794ac3fd45937fa1cbc0fcb9d54a3ede4d831f76d0
+DIST rcs-5.10.1.tar.lz 917331 BLAKE2B bf439b2bbb6d5d427f28b13d739f2a5902aa3113e958528028ff553007ad124a8c386141e10ff2d0157468d893e1da4a19240acb373a3f375aa21d97c187a4dd SHA512 4d3755d704a05da8582acb78a83845885f34b3144af6d19c568e6707831563b077ec5603a12f5d4de6ec583d0886d3a8ccc7ee0e1f10070f9e6de142198cd530
diff --git a/dev-vcs/rcs/rcs-5.10.1.ebuild b/dev-vcs/rcs/rcs-5.10.1.ebuild
new file mode 100644
index 000000000000..ca3111c83974
--- /dev/null
+++ b/dev-vcs/rcs/rcs-5.10.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic unpacker
+
+DESCRIPTION="Revision Control System"
+HOMEPAGE="https://www.gnu.org/software/rcs/"
+SRC_URI="mirror://gnu/rcs/${P}.tar.lz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris"
+IUSE="doc"
+
+RDEPEND="sys-apps/diffutils
+ sys-apps/ed"
+DEPEND="${RDEPEND}"
+BDEPEND="$(unpacker_src_uri_depends)"
+
+src_prepare() {
+ default
+
+ sed -i -e '/gets is a security hole/d' \
+ lib/stdio.in.h || die
+}
+
+src_configure() {
+ append-flags -std=gnu99
+
+ econf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ dodoc ChangeLog NEWS README
+
+ if use doc; then
+ emake -C doc html
+ rm -R "${ED}"/usr/share/doc/rcs || die
+ mv doc/rcs.html doc/html || die
+ dodoc -r doc/html/
+ fi
+}