summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2023-11-06 11:36:41 +0000
committerMarek Szuba <marecki@gentoo.org>2023-11-06 15:00:45 +0000
commit2d2264f3830c1c14acd266a00577be7a86020723 (patch)
tree9fd30b7627d991dc413629461dc11cdf651b271f /dev-vcs
parentdev-python/grpcio: destabilize 1.51.0-r1 for ~amd64, ~x86 (diff)
downloadgentoo-2d2264f3830c1c14acd266a00577be7a86020723.tar.gz
gentoo-2d2264f3830c1c14acd266a00577be7a86020723.tar.bz2
gentoo-2d2264f3830c1c14acd266a00577be7a86020723.zip
dev-vcs/pre-commit: deselect tests that fail if pre-commit is installed
On the one hand quite a few bits of pre-commit rely on the executable "git" being present in PATH, on the other the tests delete the directory containing "pre-commit" from PATH prior to executing. If both reside in /usr/bin, hilarity ensues. Just deselect these tests, they aren't directly relevant to packaged pre-commit anyway. Thanks-to: Alfred Wingate <parona@protonmail.com> Closes: https://bugs.gentoo.org/894502 Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/pre-commit/pre-commit-3.3.3.ebuild13
-rw-r--r--dev-vcs/pre-commit/pre-commit-3.5.0.ebuild13
2 files changed, 16 insertions, 10 deletions
diff --git a/dev-vcs/pre-commit/pre-commit-3.3.3.ebuild b/dev-vcs/pre-commit/pre-commit-3.3.3.ebuild
index 57b3ece298ad..754a0991d794 100644
--- a/dev-vcs/pre-commit/pre-commit-3.3.3.ebuild
+++ b/dev-vcs/pre-commit/pre-commit-3.3.3.ebuild
@@ -41,17 +41,20 @@ PATCHES=(
DOCS=( CHANGELOG.md CONTRIBUTING.md README.md )
-# The former two require a boatload of dependencies (e.g. Conda, Go, R and more) in order to run
-# and while some of them do include "skip if not found" logic, most of them do not.
-# The latter consistently fail with
-# Calling "git rev-parse" fails with "fatal: not a git repository (or any of the parent directories): .git".
-# including with the sandbox disabled.
EPYTEST_DESELECT=(
+ # All of these require a boatload of dependencies (e.g. Conda, Go, R and more) in order to run
+ # and while some of them do include "skip if not found" logic, most of them do not.
tests/languages/
tests/repository_test.py
+ # These three consistently fail with
+ # Calling "git rev-parse" fails with "fatal: not a git repository (or any of the parent directories): .git".
+ # including with the sandbox disabled.
tests/main_test.py::test_all_cmds
tests/main_test.py::test_hook_stage_migration
tests/main_test.py::test_try_repo
+ # These two fail if pre-commit is already installed (Bug #894502)
+ tests/commands/install_uninstall_test.py::test_environment_not_sourced
+ tests/commands/install_uninstall_test.py::test_installed_from_venv
)
distutils_enable_tests pytest
diff --git a/dev-vcs/pre-commit/pre-commit-3.5.0.ebuild b/dev-vcs/pre-commit/pre-commit-3.5.0.ebuild
index e6d46da41754..96ec1f982805 100644
--- a/dev-vcs/pre-commit/pre-commit-3.5.0.ebuild
+++ b/dev-vcs/pre-commit/pre-commit-3.5.0.ebuild
@@ -42,17 +42,20 @@ PATCHES=(
DOCS=( CHANGELOG.md CONTRIBUTING.md README.md )
-# The former two require a boatload of dependencies (e.g. Conda, Go, R and more) in order to run
-# and while some of them do include "skip if not found" logic, most of them do not.
-# The latter consistently fail with
-# Calling "git rev-parse" fails with "fatal: not a git repository (or any of the parent directories): .git".
-# including with the sandbox disabled.
EPYTEST_DESELECT=(
+ # All of these require a boatload of dependencies (e.g. Conda, Go, R and more) in order to run
+ # and while some of them do include "skip if not found" logic, most of them do not.
tests/languages/
tests/repository_test.py
+ # These three consistently fail with
+ # Calling "git rev-parse" fails with "fatal: not a git repository (or any of the parent directories): .git".
+ # including with the sandbox disabled.
tests/main_test.py::test_all_cmds
tests/main_test.py::test_hook_stage_migration
tests/main_test.py::test_try_repo
+ # These two fail if pre-commit is already installed (Bug #894502)
+ tests/commands/install_uninstall_test.py::test_environment_not_sourced
+ tests/commands/install_uninstall_test.py::test_installed_from_venv
)
distutils_enable_tests pytest