summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2022-11-27 01:39:23 +0100
committerSebastian Pipping <sping@gentoo.org>2022-11-27 01:42:39 +0100
commitecd053a8db9abdc32450577c4328e926f50bf520 (patch)
treed5b76906dc41d4b2542ee18aa5870edbbe607a89 /dev-vcs
parentdev-vcs/git-delete-merged-branches: DistutilsNonPEP517Build + MissingRemoteId (diff)
downloadgentoo-ecd053a8db9abdc32450577c4328e926f50bf520.tar.gz
gentoo-ecd053a8db9abdc32450577c4328e926f50bf520.tar.bz2
gentoo-ecd053a8db9abdc32450577c4328e926f50bf520.zip
dev-vcs/git-big-picture: Python 3.11 + MissingRemoteId
Signed-off-by: Sebastian Pipping <sping@gentoo.org>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/git-big-picture/git-big-picture-1.2.2-r1.ebuild41
-rw-r--r--dev-vcs/git-big-picture/metadata.xml4
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-vcs/git-big-picture/git-big-picture-1.2.2-r1.ebuild b/dev-vcs/git-big-picture/git-big-picture-1.2.2-r1.ebuild
new file mode 100644
index 000000000000..26cb5b466ea7
--- /dev/null
+++ b/dev-vcs/git-big-picture/git-big-picture-1.2.2-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+# DISTUTILS_USE_PEP517=setuptools # blocked by use of distutils_install_for_testing
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Visualization tool for Git repositories"
+HOMEPAGE="https://github.com/git-big-picture/git-big-picture"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="
+ test? (
+ dev-python/parameterized[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-util/cram[${PYTHON_USEDEP}]
+ )
+"
+# No need for "[python]" or "[${PYTHON_USEDEP}]" with any of these
+# since they are invoked using subprocess
+RDEPEND="
+ dev-vcs/git
+ media-gfx/graphviz[svg]
+"
+
+RESTRICT="!test? ( test )"
+
+python_test() {
+ pytest -vv test.py || die "Tests fail with ${EPYTHON}"
+
+ distutils_install_for_testing
+ cram test.cram || die "Tests fail with ${EPYTHON}"
+}
diff --git a/dev-vcs/git-big-picture/metadata.xml b/dev-vcs/git-big-picture/metadata.xml
index 6a22e9e318bb..eb74f28cf75b 100644
--- a/dev-vcs/git-big-picture/metadata.xml
+++ b/dev-vcs/git-big-picture/metadata.xml
@@ -5,4 +5,8 @@
<email>sping@gentoo.org</email>
<name>Sebastian Pipping</name>
</maintainer>
+ <upstream>
+ <remote-id type="github">git-big-picture/git-big-picture</remote-id>
+ <remote-id type="pypi">git-big-picture</remote-id>
+ </upstream>
</pkgmetadata>