summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-action/geki2-KXL/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-action/geki2-KXL/files')
-rw-r--r--games-action/geki2-KXL/files/geki2-KXL-2.0.3-cflags.patch9
-rw-r--r--games-action/geki2-KXL/files/geki2-KXL-2.0.3-paths.patch44
2 files changed, 53 insertions, 0 deletions
diff --git a/games-action/geki2-KXL/files/geki2-KXL-2.0.3-cflags.patch b/games-action/geki2-KXL/files/geki2-KXL-2.0.3-cflags.patch
new file mode 100644
index 000000000000..9812e6de30aa
--- /dev/null
+++ b/games-action/geki2-KXL/files/geki2-KXL-2.0.3-cflags.patch
@@ -0,0 +1,9 @@
+--- src/Makefile.am.old 2012-11-10 21:50:02.159117541 +0100
++++ src/Makefile.am 2012-11-10 21:50:20.658715770 +0100
+@@ -4,5 +4,5 @@
+ boss.h extern.h ranking.h your.h game.h\
+ geki2.h load.h opening.h my.h misc.h
+
+-CFLAGS = @X_CFLAGS@ @KXL_CFLAGS@
++AM_CFLAGS = @X_CFLAGS@ @KXL_CFLAGS@
+ LIBS = @X_LIBS@ -lX11 @KXL_LIBS@ -lKXL
diff --git a/games-action/geki2-KXL/files/geki2-KXL-2.0.3-paths.patch b/games-action/geki2-KXL/files/geki2-KXL-2.0.3-paths.patch
new file mode 100644
index 000000000000..1e4d7dba67d8
--- /dev/null
+++ b/games-action/geki2-KXL/files/geki2-KXL-2.0.3-paths.patch
@@ -0,0 +1,44 @@
+--- bmp/Makefile.am
++++ bmp/Makefile.am
+@@ -1,4 +1,4 @@
+-bmpdir = $(prefix)/share/geki2/bmp
++bmpdir = $(BMP_PATH)
+ bmp_DATA = back1.bmp boss2.bmp enemyshot4.bmp kuru.bmp myshot.bmp back2.bmp\
+ boss3.bmp enemyshot5.bmp mboss.bmp uraura.bmp back3.bmp\
+ boss3laser.bmp flash.bmp uturn.bmp back4.bmp back6.bmp boss6.bmp\
+--- configure.in
++++ configure.in
+@@ -25,9 +25,9 @@
+ BMP_PATH=/usr/local/share/geki2/bmp
+ WAV_PATH=/usr/local/share/geki2/wav
+ else
+- DATA_PATH=$prefix/share/geki2/data
+- BMP_PATH=$prefix/share/geki2/bmp
+- WAV_PATH=$prefix/share/geki2/wav
++ DATA_PATH=$datadir/geki2/data
++ BMP_PATH=$datadir/geki2/bmp
++ WAV_PATH=$datadir/geki2/wav
+ fi
+ AC_DEFINE_UNQUOTED(DATA_PATH,"$DATA_PATH")
+ AC_DEFINE_UNQUOTED(BMP_PATH,"$BMP_PATH")
+--- data/Makefile.am
++++ data/Makefile.am
+@@ -1,9 +1,7 @@
+-datadir = $(prefix)/share/geki2/data
++datadir = $(DATA_PATH)
+ data_DATA = stage1.dat stage2.dat stage3.dat stage4.dat stage5.dat stage6.dat\
+ map1.dat map2.dat map3.dat map4.dat map5.dat map6.dat
+ EXTRA_DIST = stage1.dat stage2.dat stage3.dat stage4.dat stage5.dat stage6.dat\
+ map1.dat map2.dat map3.dat map4.dat map5.dat map6.dat .score
+
+-install:
+- $(INSTALL) -c -m 666 ./.score $(DESTDIR)$(DATA_PATH)
+
+--- wav/Makefile.am
++++ wav/Makefile.am
+@@ -1,4 +1,4 @@
+-wavdir = $(prefix)/share/geki2/wav
++wavdir = $(WAV_PATH)
+ wav_DATA = bgm1.wav bgm2.wav bgm3.wav bgm4.wav bgm5.wav\
+ bomb.wav laser5.wav warning.wav boss.wav open.wav\
+ laser.wav pow.wav go.wav bgm6.wav