summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-arcade/sdb/sdb-1.0.2.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-arcade/sdb/sdb-1.0.2.ebuild')
-rw-r--r--games-arcade/sdb/sdb-1.0.2.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/games-arcade/sdb/sdb-1.0.2.ebuild b/games-arcade/sdb/sdb-1.0.2.ebuild
new file mode 100644
index 000000000000..f73cee74bcc9
--- /dev/null
+++ b/games-arcade/sdb/sdb-1.0.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="a 2D top-down action game; escape a facility full of walking death machines"
+HOMEPAGE="http://sdb.gamecreation.org/"
+SRC_URI="http://gcsociety.sp.cs.cmu.edu/~frenzy/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE=""
+
+DEPEND="virtual/opengl
+ media-libs/libsdl
+ media-libs/sdl-image[png]
+ media-libs/sdl-mixer"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i \
+ -e "s:models/:${GAMES_DATADIR}/${PN}/models/:" \
+ -e "s:snd/:${GAMES_DATADIR}/${PN}/snd/:" \
+ -e "s:sprites/:${GAMES_DATADIR}/${PN}/sprites/:" \
+ -e "s:levels/:${GAMES_DATADIR}/${PN}/levels/:" \
+ src/sdb.h src/game.cpp || die "setting game paths"
+ epatch \
+ "${FILESDIR}"/${P}-endian.patch \
+ "${FILESDIR}"/${P}-gcc43.patch \
+ "${FILESDIR}"/${P}-ldflags.patch
+}
+
+src_compile() {
+ emake \
+ -C src \
+ CXXFLAGS="${CXXFLAGS} $(sdl-config --cflags)"
+}
+
+src_install() {
+ dogamesbin src/sdb
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r levels models snd sprites
+ newicon sprites/barrel.png ${PN}.png
+ make_desktop_entry sdb "Shotgun Debugger"
+ dodoc ChangeLog README
+ prepgamesdirs
+}