summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-arcade/spacerider
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-arcade/spacerider')
-rw-r--r--games-arcade/spacerider/Manifest1
-rw-r--r--games-arcade/spacerider/files/spacerider-0.13-font.patch14
-rw-r--r--games-arcade/spacerider/files/spacerider-0.13-gcc41.patch10
-rw-r--r--games-arcade/spacerider/files/spacerider-0.13-gcc49.patch22
-rw-r--r--games-arcade/spacerider/files/spacerider-0.13-gentoo.patch27
-rw-r--r--games-arcade/spacerider/files/spacerider-0.13-ovflfix.patch11
-rw-r--r--games-arcade/spacerider/metadata.xml8
-rw-r--r--games-arcade/spacerider/spacerider-0.13.ebuild43
8 files changed, 136 insertions, 0 deletions
diff --git a/games-arcade/spacerider/Manifest b/games-arcade/spacerider/Manifest
new file mode 100644
index 000000000000..6293196accaf
--- /dev/null
+++ b/games-arcade/spacerider/Manifest
@@ -0,0 +1 @@
+DIST spacerider-0.13.tar.bz2 283861 SHA256 9314945b7004a64e7f511b7318af3aef5d1ab680577ba97399a8a11ab022678e SHA512 4f8d506abfe242039247d5c4e43c012ded14f3b18de710aea0c9c6d933cb60fde3116008723d44acadd490b3666e107506fad6ee027d2b31c47d118185e0c03e WHIRLPOOL f75ca582565289896ef6e8c0036d0570e03263370fd290ac472aab969c0c9125fb3e1f5f25a9f4266f32e77f4a9b0852d7ac7dd902100624d44c098a0899b6c2
diff --git a/games-arcade/spacerider/files/spacerider-0.13-font.patch b/games-arcade/spacerider/files/spacerider-0.13-font.patch
new file mode 100644
index 000000000000..914a0466c7fe
--- /dev/null
+++ b/games-arcade/spacerider/files/spacerider-0.13-font.patch
@@ -0,0 +1,14 @@
+Ugly brute-force method for avoiding a double-free segfault on exit.
+Better patch welcome.
+
+--- spacerider.cpp.orig 2015-03-31 23:24:17.770966147 -0400
++++ spacerider.cpp 2015-03-31 23:24:41.592174463 -0400
+@@ -306,8 +306,6 @@
+ /* free screen */
+ SDL_FreeSurface(screen);
+ }
+- /* call the TTF-Library cleanup function */
+- TTF_Quit();
+
+ /* call the NET-Library cleanup function */
+ SDLNet_Quit();
diff --git a/games-arcade/spacerider/files/spacerider-0.13-gcc41.patch b/games-arcade/spacerider/files/spacerider-0.13-gcc41.patch
new file mode 100644
index 000000000000..1a08d715ac5b
--- /dev/null
+++ b/games-arcade/spacerider/files/spacerider-0.13-gcc41.patch
@@ -0,0 +1,10 @@
+--- spacerider.cpp.old 2007-02-18 11:25:38.000000000 +0100
++++ spacerider.cpp 2007-02-18 11:27:00.000000000 +0100
+@@ -17,6 +17,7 @@
+ #include <unistd.h>
+ }
+
++int send_score_thread(void *param);
+
+ Spacerider::Spacerider(const int argc, char *argv[]) : fullscreen(FULLSCREEN), game_over(false), online_highscore(ONLINE_HIGHSCORE), score_sent(false), name_input(true), highscore_thread_started(false), scroll(0), last_enemy(0), score(0), lives(LIVES), fps(FPS)
+ {
diff --git a/games-arcade/spacerider/files/spacerider-0.13-gcc49.patch b/games-arcade/spacerider/files/spacerider-0.13-gcc49.patch
new file mode 100644
index 000000000000..d057e7bab730
--- /dev/null
+++ b/games-arcade/spacerider/files/spacerider-0.13-gcc49.patch
@@ -0,0 +1,22 @@
+--- effect.cpp.orig 2015-03-31 22:36:53.336131373 -0400
++++ effect.cpp 2015-03-31 22:37:04.359755281 -0400
+@@ -18,7 +18,7 @@
+ void Effect::add(const int x, const int y)
+ {
+ object_struct *effect;
+- if((effect = add_object(x, y)) == NULL)
++ if((effect = add_object(x, y, 0, 0)) == NULL)
+ {
+ return;
+ }
+--- object.h.orig 2015-03-31 22:35:22.939214561 -0400
++++ object.h 2015-03-31 22:37:19.654233441 -0400
+@@ -172,7 +172,7 @@
+ return object->next;
+ }
+
+-template <class T>struct Object<T>::object_struct *Object<T>::add_object(const int x, const int y, const int speedx = 0, const int speedy = 0)
++template <class T>struct Object<T>::object_struct *Object<T>::add_object(const int x, const int y, const int speedx, const int speedy)
+ {
+ object_struct *object;
+
diff --git a/games-arcade/spacerider/files/spacerider-0.13-gentoo.patch b/games-arcade/spacerider/files/spacerider-0.13-gentoo.patch
new file mode 100644
index 000000000000..d692f87632b0
--- /dev/null
+++ b/games-arcade/spacerider/files/spacerider-0.13-gentoo.patch
@@ -0,0 +1,27 @@
+--- Makefile
++++ Makefile
+@@ -3,12 +3,12 @@
+ BINDIR=/usr/bin/
+ MANDIR=/usr/share/man/man1/
+ DATADIR=/usr/share/games/spacerider/
+-CXX=g++
++CXX?=g++
+ CP=cp
+ MKDIR=mkdir -p
+ INSTALL=install
+ RM=rm -f
+-CXXFLAGS=-Wall -fomit-frame-pointer -O3 `sdl-config --cflags`
++CXXFLAGS+=$(shell sdl-config --cflags)
+ OBJS=main.o globals.o spacerider.o music.o sprite.o enemy.o effect.o visible.o box.o features.o font.o image.o bullet.o
+ OUTPUT=spacerider
+ LIBS=`sdl-config --libs` -lSDL_image -lSDL_ttf -lSDL_mixer -lSDL_net -lSDL_gfx
+@@ -22,8 +22,7 @@
+
+
+ $(OUTPUT): $(OBJS)
+- $(CXX) $(CXXFLAGS) -o $(OUTPUT) $(OBJS) $(LIBS)
+- strip $(OUTPUT)
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) -o $(OUTPUT) $(OBJS) $(LIBS)
+
+ %.o: %.cpp
+ $(CXX) $(CXXFLAGS) -c $<
diff --git a/games-arcade/spacerider/files/spacerider-0.13-ovflfix.patch b/games-arcade/spacerider/files/spacerider-0.13-ovflfix.patch
new file mode 100644
index 000000000000..5ed73c348cf2
--- /dev/null
+++ b/games-arcade/spacerider/files/spacerider-0.13-ovflfix.patch
@@ -0,0 +1,11 @@
+--- spacerider.cpp.old 2010-10-29 10:12:19.000000000 +0200
++++ spacerider.cpp 2010-10-29 10:13:47.000000000 +0200
+@@ -112,7 +112,7 @@
+ break;
+ case 'n':
+ /* specify a name for the online-highscore */
+- strncpy(name, optarg, 128);
++ strncpy(name, optarg, sizeof (name));
+ online_highscore = true;
+ break;
+ case 't':
diff --git a/games-arcade/spacerider/metadata.xml b/games-arcade/spacerider/metadata.xml
new file mode 100644
index 000000000000..84cc44534ddb
--- /dev/null
+++ b/games-arcade/spacerider/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+<longdescription lang="en">
+spacerider is a space-shooter written in C++, using the SDL.
+</longdescription>
+</pkgmetadata>
diff --git a/games-arcade/spacerider/spacerider-0.13.ebuild b/games-arcade/spacerider/spacerider-0.13.ebuild
new file mode 100644
index 000000000000..92286547735f
--- /dev/null
+++ b/games-arcade/spacerider/spacerider-0.13.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="space-shooter written in C++, using the SDL"
+HOMEPAGE="http://www.hackl.dhs.org/spacerider/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2" # stupid php script
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl[sound,video]
+ media-libs/sdl-gfx
+ media-libs/sdl-mixer
+ media-libs/sdl-image[jpeg]
+ media-libs/sdl-net
+ media-libs/sdl-ttf"
+RDEPEND=${DEPEND}
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}"-gentoo.patch \
+ "${FILESDIR}/${P}"-gcc41.patch \
+ "${FILESDIR}"/${P}-ovflfix.patch \
+ "${FILESDIR}"/${P}-gcc49.patch \
+ "${FILESDIR}"/${P}-font.patch
+ sed -i \
+ -e "s:/usr/share/games/spacerider:${GAMES_DATADIR}/${PN}:" \
+ globals.cpp || die
+}
+
+src_install() {
+ dogamesbin ${PN}
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins -r data
+ dodoc AUTHORS
+ newman ${PN}.{1,6}
+ prepgamesdirs
+}