summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNHOrus <jy6x2b32pie9@yahoo.com>2024-04-04 15:29:45 +0400
committerJames Le Cuirot <chewi@gentoo.org>2024-04-05 22:23:57 +0100
commit6f862997baedb1083495e0c16c206ee42ce84f75 (patch)
tree730027425cbc73a15ec8ca393c044905086341ee /games-arcade
parentprofiles: Last rite games-board/xmille (diff)
downloadgentoo-6f862997baedb1083495e0c16c206ee42ce84f75.tar.gz
gentoo-6f862997baedb1083495e0c16c206ee42ce84f75.tar.bz2
gentoo-6f862997baedb1083495e0c16c206ee42ce84f75.zip
games-arcade/xjump: Fix C99 incompatible function pointer types
This is how C does polymorphism Fix: https://bugs.gentoo.org/882927 Signed-off-by: NHOrus <jy6x2b32pie9@yahoo.com> Closes: https://github.com/gentoo/gentoo/pull/36094 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/xjump/files/xjump-2.7.5-c99.patch16
-rw-r--r--games-arcade/xjump/xjump-2.7.5-r2.ebuild3
2 files changed, 18 insertions, 1 deletions
diff --git a/games-arcade/xjump/files/xjump-2.7.5-c99.patch b/games-arcade/xjump/files/xjump-2.7.5-c99.patch
new file mode 100644
index 000000000000..1f2958faf686
--- /dev/null
+++ b/games-arcade/xjump/files/xjump-2.7.5-c99.patch
@@ -0,0 +1,16 @@
+Polymorphism, C way
+--- a/record.c 2024-04-04 11:22:00.801603415 +0000
++++ b/record.c 2024-04-04 11:26:16.515731335 +0000
+@@ -198,8 +198,11 @@
+
+ /* ¥½¡¼¥ÈÈæ³Ó´Ø¿ô */
+
+-static int sort_cmp( record_t *r1, record_t *r2 )
++static int sort_cmp(const void *v1, const void *v2 )
+ {
++ const record_t *r1 = (const record_t *) v1;
++ const record_t *r2 = (const record_t *) v2;
++
+ if( r1->score > r2->score )
+ return -1;
+ else if( r1->score < r2->score )
diff --git a/games-arcade/xjump/xjump-2.7.5-r2.ebuild b/games-arcade/xjump/xjump-2.7.5-r2.ebuild
index 7dacc1d1aa39..3800e1924c0f 100644
--- a/games-arcade/xjump/xjump-2.7.5-r2.ebuild
+++ b/games-arcade/xjump/xjump-2.7.5-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -32,6 +32,7 @@ PATCHES=(
"${WORKDIR}"/debian/patches/04_makefile_respect_cflags.patch
"${WORKDIR}"/debian/patches/05_unneded_deps.patch
"${FILESDIR}"/${P}-ldflags.patch
+ "${FILESDIR}"/${P}-c99.patch
)
src_prepare() {