summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-07-11 00:36:32 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-07-11 01:25:14 -0400
commit5e25cc8474180b45b0465852d31a9f1a132aaffe (patch)
treefda0d4e49be276526e448faa303dcb686b417afd /games-board/pysolfc
parentnet-misc/teamviewer: add 15.42.4 (diff)
downloadgentoo-5e25cc8474180b45b0465852d31a9f1a132aaffe.tar.gz
gentoo-5e25cc8474180b45b0465852d31a9f1a132aaffe.tar.bz2
gentoo-5e25cc8474180b45b0465852d31a9f1a132aaffe.zip
games-board/pysolfc: add 2.21.0
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-board/pysolfc')
-rw-r--r--games-board/pysolfc/Manifest1
-rw-r--r--games-board/pysolfc/pysolfc-2.21.0.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/games-board/pysolfc/Manifest b/games-board/pysolfc/Manifest
index f4c54f90bbf3..eb39c9a41115 100644
--- a/games-board/pysolfc/Manifest
+++ b/games-board/pysolfc/Manifest
@@ -1,3 +1,4 @@
DIST PySolFC-2.20.1.tar.xz 9175764 BLAKE2B 3eba9044cc37f96d85e51f5bb5faa5605e8a5de887fe0c73a9bea7dde1a49e63263d7a9b66113e975a26d71de2611e0b5dc176713734316b8c0410fb8145a539 SHA512 f801dacfb3f538496a7dd2fd1777897681521928fe7ea8aec7ea514c1422e8d4ad6c0943ba534914d95544d8eb5e4868f860e6864a8e105f6cc0d16a3d678346
+DIST PySolFC-2.21.0.tar.xz 20021468 BLAKE2B afb73675ab57ffbad96b3a6113733494343c481d18651c0932a2da28d58649a67031d280b49ee31b672abe2ca840d0ce1bb92f7e498f5fc567524eb7bdb26792 SHA512 7e2f4d45810288880a8b0d866110be00805c27d20dc94a4393079b94579253ee6bc1ed7355752842faf092d7a1bfe03ec4c3d6e1e61f2ddb39b959b3a830448d
DIST PySolFC-Cardsets--Minimal-2.2.0.tar.xz 23145612 BLAKE2B f98e51c9609bda850cf39ffcd255c7d5c729bc01c35475b1f99a4a4d4ec6a436d44d7e5ecdcce3726616aeaff19617dba6735861f6c5677d2c197882d631a475 SHA512 d5eb0753d14e0758f410d843f553ca6c03acc6d4283b447016e959c889c9dada29fa3facead44354782010b52ec51e0d095858d3b78243ad5280068ec6cd3e31
DIST PySolFC-Cardsets-2.2.tar.bz2 65408375 BLAKE2B 7c0f4bb245d628222e0c8e3b56739c52d77aa6f62088b547c077368591ac3632300a9a35145ddbc33bfdf3accd91d261d103be6777db8c3cbb5576683358b0de SHA512 5562e572909eba96399c79487127b3d98c8f0e1ad145469e48fd6c3803334ba11c41e403d7dcaab5cd01324219426f7afdba9459d97b03071dd67b6dd73ce304
diff --git a/games-board/pysolfc/pysolfc-2.21.0.ebuild b/games-board/pysolfc/pysolfc-2.21.0.ebuild
new file mode 100644
index 000000000000..02b36f4c990c
--- /dev/null
+++ b/games-board/pysolfc/pysolfc-2.21.0.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_REQ_USE="tk"
+inherit distutils-r1 xdg
+
+MY_PN="PySolFC"
+MY_P="${MY_PN}-${PV}"
+PS_CARD_P="${MY_PN}-Cardsets-2.2"
+PS_CARD_MIN_P="${MY_PN}-Cardsets--Minimal-2.2.0"
+
+DESCRIPTION="Exciting collection of more than 1000 solitaire card games"
+HOMEPAGE="https://pysolfc.sourceforge.io/"
+SRC_URI="mirror://sourceforge/pysolfc/${MY_P}.tar.xz
+ extra-cardsets? ( mirror://sourceforge/pysolfc/${PS_CARD_P}.tar.bz2 )
+ !extra-cardsets? ( mirror://sourceforge/pysolfc/${PS_CARD_MIN_P}.tar.xz )"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-3+ GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="extra-cardsets minimal +sound"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/attrs[${PYTHON_USEDEP}]
+ dev-python/configobj[${PYTHON_USEDEP}]
+ dev-python/pysol_cards[${PYTHON_USEDEP}]
+ dev-python/random2[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ sound? ( dev-python/pygame[${PYTHON_USEDEP}] )
+ !minimal? ( dev-python/pillow[jpeg,tk,${PYTHON_USEDEP}] )')
+ !minimal? ( dev-tcltk/tktable )"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # make pip check happier, pycotap is not needed
+ sed -i "/'pycotap'/d" setup.py || die
+
+ if use extra-cardsets; then
+ find ../${PS_CARD_P} -type d -name .thumbnails -exec rm -r {} + || die
+ fi
+}
+
+python_install_all() {
+ local DOCS=( AUTHORS.md NEWS.asciidoc README.md )
+ distutils-r1_python_install_all
+
+ doman docs/pysol{,fc}.6
+
+ insinto /usr/share/${MY_PN}
+ doins -r ../$(usex extra-cardsets ${PS_CARD_P} ${PS_CARD_MIN_P})/.
+
+ # html files are used at runtime, keep at default location
+ dosym -r /usr/share/{${MY_PN},doc/${PF}}/html
+
+ # russian translation is not currently displaying right
+ # https://forums.gentoo.org/viewtopic-t-1142910.html
+ rm "${ED}"/usr/share/locale/ru/LC_MESSAGES/pysol.mo || die
+}