summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Sokolov <sokolov@google.com>2020-09-03 22:17:18 +0100
committerJames Le Cuirot <chewi@gentoo.org>2020-09-10 23:06:30 +0100
commitf8b267e11eb17e00f6c9ac273a4ad3efd702b724 (patch)
treee9e49d217c8de70da92bcde2e193ac106d80fac3 /games-board/sjeng/sjeng-11.2_p8_p1.ebuild
parentdev-python/fsspec: Bump to 0.8.2 (diff)
downloadgentoo-f8b267e11eb17e00f6c9ac273a4ad3efd702b724.tar.gz
gentoo-f8b267e11eb17e00f6c9ac273a4ad3efd702b724.tar.bz2
gentoo-f8b267e11eb17e00f6c9ac273a4ad3efd702b724.zip
games-board/sjeng: apply debian patches
Install missing files Closes: https://bugs.gentoo.org/707270 Package-Manager: Portage-3.0.4, Repoman-2.3.23 Signed-off-by: Alexey Sokolov <alexey+gentoo@asokolov.org> Closes: https://github.com/gentoo/gentoo/pull/17407 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'games-board/sjeng/sjeng-11.2_p8_p1.ebuild')
-rw-r--r--games-board/sjeng/sjeng-11.2_p8_p1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/games-board/sjeng/sjeng-11.2_p8_p1.ebuild b/games-board/sjeng/sjeng-11.2_p8_p1.ebuild
new file mode 100644
index 000000000000..19dd36910973
--- /dev/null
+++ b/games-board/sjeng/sjeng-11.2_p8_p1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit prefix
+
+MY_PV=$(ver_cut 1-2)
+# 11.2_p8_p1 -> 11.2-8.1
+MY_DEB_PV="${MY_PV}-$(ver_cut 4).$(ver_cut 6)"
+
+DESCRIPTION="Console based chess interface"
+HOMEPAGE="http://sjeng.sourceforge.net/"
+SRC_URI="
+ mirror://sourceforge/sjeng/Sjeng-Free-${MY_PV}.tar.gz
+ http://deb.debian.org/debian/pool/main/s/sjeng/sjeng_${MY_DEB_PV}.diff.gz
+"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE=""
+
+RDEPEND="sys-libs/gdbm:0="
+DEPEND="${RDEPEND}"
+BDEPEND="dev-util/quilt"
+
+S="${WORKDIR}/Sjeng-Free-${MY_PV}"
+
+src_prepare() {
+ default
+
+ eapply "${WORKDIR}/sjeng_${MY_DEB_PV}.diff"
+ QUILT_PATCHES="debian/patches" QUILT_SERIES="debian/patches/series" quilt push -a || die
+ hprefixify book.c rcfile.c
+}
+
+src_install() {
+ default
+
+ insinto /etc
+ doins sjeng.rc
+ insinto /usr/share/games/sjeng
+ doins books/*.opn || die
+}