summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-emulation/gcube
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-emulation/gcube')
-rw-r--r--games-emulation/gcube/Manifest1
-rw-r--r--games-emulation/gcube/files/gcube-0.4-gcc47.patch10
-rw-r--r--games-emulation/gcube/files/gcube-0.4-ldflags.patch30
-rw-r--r--games-emulation/gcube/files/gcube-0.4-underlink.patch10
-rw-r--r--games-emulation/gcube/gcube-0.4-r1.ebuild44
-rw-r--r--games-emulation/gcube/metadata.xml5
6 files changed, 100 insertions, 0 deletions
diff --git a/games-emulation/gcube/Manifest b/games-emulation/gcube/Manifest
new file mode 100644
index 000000000000..be0bc7dbc11e
--- /dev/null
+++ b/games-emulation/gcube/Manifest
@@ -0,0 +1 @@
+DIST gcube-0.4-src.tar.bz2 803503 SHA256 e2fe9b198ea627ec6b1be98b06a620d1f32f373c94161ea042319dbf6cb10418 SHA512 f73665386d547322f20ed5e358f4f394b07d74fd90bddbfe1158a7a5d896bff36dabc9833f2d820a7af7673b8c8af62490f7fa07b06a2bbca4df6356a1e3c91a WHIRLPOOL d36dbe8aff85acfdd8ab7faec11c452fff8a74b8aea2c7dbaa824a8308c89474e30d2b49fef20048ea773c0406550808717eeffba1a3c8b13f01931c0365e63f
diff --git a/games-emulation/gcube/files/gcube-0.4-gcc47.patch b/games-emulation/gcube/files/gcube-0.4-gcc47.patch
new file mode 100644
index 000000000000..b459a4e24034
--- /dev/null
+++ b/games-emulation/gcube/files/gcube-0.4-gcc47.patch
@@ -0,0 +1,10 @@
+--- Makefile.rules.old 2012-10-23 14:06:54.417782365 +0200
++++ Makefile.rules 2012-10-23 14:07:11.516377033 +0200
+@@ -1,6 +1,6 @@
+
+ SDL_CONFIG=sdl-config
+-LIBS=`$(SDL_CONFIG) --libs` -mno-windows -mcygwin -lz -l$(OPENGL) -lm
++LIBS=`$(SDL_CONFIG) --libs` -lz -l$(OPENGL) -lm
+
+ PROFLAGS=-g -Wall -pg -fprofile-arcs -ftest-coverage
+ OPTFLAGS=-O3 -fno-strict-aliasing -fomit-frame-pointer -ffast-math -march=$(CPU) $(OPTIMIZE)
diff --git a/games-emulation/gcube/files/gcube-0.4-ldflags.patch b/games-emulation/gcube/files/gcube-0.4-ldflags.patch
new file mode 100644
index 000000000000..169472ee1851
--- /dev/null
+++ b/games-emulation/gcube/files/gcube-0.4-ldflags.patch
@@ -0,0 +1,30 @@
+--- Makefile.rules.old 2010-10-01 07:16:16.000000000 +0200
++++ Makefile.rules 2010-10-01 07:18:04.000000000 +0200
+@@ -88,22 +88,22 @@
+ profiler: default
+
+ gcube: $(OBJECTS) gcube.o
+- $(CC) $(CFLAGS) $^ -o $@ $(LIBS)
++ $(CC) $(LDFLAGS) $(CFLAGS) $^ -o $@ $(LIBS)
+
+ gcubedbg: $(OBJECTS) gcubedbg.o cpu_dbg.o
+ $(CC) $(CFLAGS) $^ -o $@ $(LIBS)
+
+ bin2dol: bin2dol.c general.o
+- $(CC) $(CFLAGS) $^ -o $@
++ $(CC) $(LDFLAGS) $(CFLAGS) $^ -o $@
+
+ tplx: tplx.o general.o
+- $(CC) $(CFLAGS) $^ -o $@
++ $(CC) $(LDFLAGS) $(CFLAGS) $^ -o $@
+
+ thpview: thpview.o general.o jpeg_tools.o
+- $(CC) $(CFLAGS) `$(SDL_CONFIG) --cflags` $^ -o $@ -ljpeg `$(SDL_CONFIG) --libs`
++ $(CC) $(LDFLAGS) $(CFLAGS) `$(SDL_CONFIG) --cflags` $^ -o $@ -ljpeg `$(SDL_CONFIG) --libs`
+
+ isopack: isopack.o general.o
+- $(CC) $(CFLAGS) $^ -o $@ -lz
++ $(CC) $(LDFLAGS) $(CFLAGS) $^ -o $@ -lz
+
+ ppc_disasm.o: ppc_disasm.c
+ $(CC) -g -c -o $@ $<
diff --git a/games-emulation/gcube/files/gcube-0.4-underlink.patch b/games-emulation/gcube/files/gcube-0.4-underlink.patch
new file mode 100644
index 000000000000..f1cff91cb158
--- /dev/null
+++ b/games-emulation/gcube/files/gcube-0.4-underlink.patch
@@ -0,0 +1,10 @@
+--- Makefile.rules.old 2011-06-10 14:14:08.372105234 +0200
++++ Makefile.rules 2011-06-10 14:14:18.504746649 +0200
+@@ -1,6 +1,6 @@
+
+ SDL_CONFIG=sdl-config
+-LIBS=`$(SDL_CONFIG) --libs` -mno-windows -mcygwin -lz -l$(OPENGL)
++LIBS=`$(SDL_CONFIG) --libs` -mno-windows -mcygwin -lz -l$(OPENGL) -lm
+
+ PROFLAGS=-g -Wall -pg -fprofile-arcs -ftest-coverage
+ OPTFLAGS=-O3 -fno-strict-aliasing -fomit-frame-pointer -ffast-math -march=$(CPU) $(OPTIMIZE)
diff --git a/games-emulation/gcube/gcube-0.4-r1.ebuild b/games-emulation/gcube/gcube-0.4-r1.ebuild
new file mode 100644
index 000000000000..4aa39cbfa4c4
--- /dev/null
+++ b/games-emulation/gcube/gcube-0.4-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="Gamecube emulator"
+HOMEPAGE="http://gcube.exemu.net/"
+SRC_URI="http://gcube.exemu.net/downloads/${P}-src.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE=""
+
+DEPEND="virtual/opengl
+ media-libs/libsdl[sound,joystick,video]
+ virtual/jpeg:0
+ sys-libs/ncurses
+ sys-libs/zlib"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${PV}
+
+src_prepare() {
+ sed -i \
+ -e '/^CFLAGS=-g/d' Makefile.rules \
+ || die "sed failed"
+ epatch "${FILESDIR}"/${P}-ldflags.patch \
+ "${FILESDIR}"/${P}-underlink.patch \
+ "${FILESDIR}"/${P}-gcc47.patch
+}
+
+src_install() {
+ local x
+
+ dogamesbin gcmap gcube
+ for x in bin2dol isopack thpview tplx ; do
+ newgamesbin ${x} ${PN}-${x}
+ done
+ dodoc ChangeLog README
+ prepgamesdirs
+}
diff --git a/games-emulation/gcube/metadata.xml b/games-emulation/gcube/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-emulation/gcube/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>