summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-01-03 20:34:09 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-01-04 10:37:21 +0100
commit7b39c6e5c4db51c5f45bb47a3e38d0da17ef95af (patch)
treee0665a5ce5c6e08888f9f76d783748602c5b92c8 /games-emulation/vbam
parentwww-client/epiphany: bump to 3.32.6 (diff)
downloadgentoo-7b39c6e5c4db51c5f45bb47a3e38d0da17ef95af.tar.gz
gentoo-7b39c6e5c4db51c5f45bb47a3e38d0da17ef95af.tar.bz2
gentoo-7b39c6e5c4db51c5f45bb47a3e38d0da17ef95af.zip
*/*: Switch games proj to cmake.eclass
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'games-emulation/vbam')
-rw-r--r--games-emulation/vbam/vbam-2.1.4.ebuild6
-rw-r--r--games-emulation/vbam/vbam-9999.ebuild6
2 files changed, 6 insertions, 6 deletions
diff --git a/games-emulation/vbam/vbam-2.1.4.ebuild b/games-emulation/vbam/vbam-2.1.4.ebuild
index a8a2590c1f1e..b19935ad2686 100644
--- a/games-emulation/vbam/vbam-2.1.4.ebuild
+++ b/games-emulation/vbam/vbam-2.1.4.ebuild
@@ -4,7 +4,7 @@
EAPI=7
WX_GTK_VER="3.0-gtk3"
-inherit wxwidgets xdg cmake-utils
+inherit wxwidgets xdg cmake
if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://github.com/visualboyadvance-m/visualboyadvance-m.git"
@@ -62,11 +62,11 @@ src_configure() {
-DENABLE_ASM_SCALERS=$(usex x86)
-DCMAKE_SKIP_RPATH=ON
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
if use sdl ; then
dodoc doc/ReadMe.SDL.txt
diff --git a/games-emulation/vbam/vbam-9999.ebuild b/games-emulation/vbam/vbam-9999.ebuild
index f8607c8a0a0e..29f851e02f7b 100644
--- a/games-emulation/vbam/vbam-9999.ebuild
+++ b/games-emulation/vbam/vbam-9999.ebuild
@@ -4,7 +4,7 @@
EAPI=7
WX_GTK_VER="3.0-gtk3"
-inherit wxwidgets xdg cmake-utils
+inherit wxwidgets xdg cmake
if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://github.com/visualboyadvance-m/visualboyadvance-m.git"
@@ -58,11 +58,11 @@ src_configure() {
-DENABLE_ASM_SCALERS=$(usex x86)
-DCMAKE_SKIP_RPATH=ON
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
if use sdl ; then
dodoc doc/ReadMe.SDL.txt