summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-07-23 19:50:54 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-07-23 19:50:54 +0200
commit9d86757bf63ca43fc97c236c616d0dfd8d8b4912 (patch)
treeb2c4de218399bb9e81966b4f3ba9bcc9803ac654 /games-emulation
parentsci-mathematics/vampire: bump to 4.7 (diff)
downloadgentoo-9d86757bf63ca43fc97c236c616d0dfd8d8b4912.tar.gz
gentoo-9d86757bf63ca43fc97c236c616d0dfd8d8b4912.tar.bz2
gentoo-9d86757bf63ca43fc97c236c616d0dfd8d8b4912.zip
games-emulation/melonds: filter lto
Closes: https://bugs.gentoo.org/858710 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/melonds/melonds-0.9.3-r2.ebuild3
-rw-r--r--games-emulation/melonds/melonds-0.9.4_p1-r1.ebuild3
-rw-r--r--games-emulation/melonds/melonds-9999.ebuild7
3 files changed, 10 insertions, 3 deletions
diff --git a/games-emulation/melonds/melonds-0.9.3-r2.ebuild b/games-emulation/melonds/melonds-0.9.3-r2.ebuild
index 0cde97c7b287..b1d97b5c25e1 100644
--- a/games-emulation/melonds/melonds-0.9.3-r2.ebuild
+++ b/games-emulation/melonds/melonds-0.9.3-r2.ebuild
@@ -6,7 +6,7 @@ EAPI=8
MY_PN="melonDS"
MY_P="${MY_PN}-${PV}"
-inherit cmake readme.gentoo-r1 toolchain-funcs xdg
+inherit cmake flag-o-matic readme.gentoo-r1 toolchain-funcs xdg
DESCRIPTION="Nintendo DS emulator, sorta"
HOMEPAGE="
@@ -58,6 +58,7 @@ PATCHES=( "${FILESDIR}"/melonds-system-teakra.patch )
src_prepare() {
rm -r ./src/teakra || die
+ filter-lto
cmake_src_prepare
}
diff --git a/games-emulation/melonds/melonds-0.9.4_p1-r1.ebuild b/games-emulation/melonds/melonds-0.9.4_p1-r1.ebuild
index 706876b372f2..33b284219a0e 100644
--- a/games-emulation/melonds/melonds-0.9.4_p1-r1.ebuild
+++ b/games-emulation/melonds/melonds-0.9.4_p1-r1.ebuild
@@ -6,7 +6,7 @@ EAPI=8
MY_PN="melonDS"
MY_P="${MY_PN}-${PV}"
-inherit cmake readme.gentoo-r1 toolchain-funcs xdg
+inherit cmake flag-o-matic readme.gentoo-r1 toolchain-funcs xdg
DESCRIPTION="Nintendo DS emulator, sorta"
HOMEPAGE="
@@ -58,6 +58,7 @@ PATCHES=( "${FILESDIR}"/melonds-system-teakra.patch )
src_prepare() {
rm -r ./src/teakra || die
+ filter-lto
cmake_src_prepare
}
diff --git a/games-emulation/melonds/melonds-9999.ebuild b/games-emulation/melonds/melonds-9999.ebuild
index 2cec9318a988..1ea9a4f84e6e 100644
--- a/games-emulation/melonds/melonds-9999.ebuild
+++ b/games-emulation/melonds/melonds-9999.ebuild
@@ -6,7 +6,7 @@ EAPI=8
MY_PN="melonDS"
MY_P="${MY_PN}-${PV}"
-inherit cmake readme.gentoo-r1 toolchain-funcs xdg
+inherit cmake flag-o-matic readme.gentoo-r1 toolchain-funcs xdg
DESCRIPTION="Nintendo DS emulator, sorta"
HOMEPAGE="
@@ -53,6 +53,11 @@ DOC_CONTENTS="You need the following files in order to run melonDS:
Place them in ~/.config/melonDS
Those files can be found somewhere on the Internet ;-)"
+src_prepare(){
+ filter-lto
+ cmake_src_prepare
+}
+
src_configure() {
local mycmakeargs=(
-DENABLE_JIT=$(usex jit)