summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-02-09 14:22:51 -0500
committerIonen Wolkens <ionen@gentoo.org>2023-02-09 15:15:07 -0500
commitfc700e6f45e842227a945f8f2d615f2c38e0e3a8 (patch)
tree5cd2d8bb00a34decc42d93ff6e5ceb0f6ba65d0d /games-emulation
parentdev-util/ruff: Make sure RUSTFLAGS is set to avoid clippy errors (bug #893740) (diff)
downloadgentoo-fc700e6f45e842227a945f8f2d615f2c38e0e3a8.tar.gz
gentoo-fc700e6f45e842227a945f8f2d615f2c38e0e3a8.tar.bz2
gentoo-fc700e6f45e842227a945f8f2d615f2c38e0e3a8.zip
games-emulation/fceux: add 2.6.5 + add USE=qt6 support
Qt6 support been there for a while, just wasn't handled here, and with the Qt6 unmasking happening soon may as well add it (still needs USE=-gles2-only, tried and fails to build if used). Also switch to github's "automated" archives for SRC_URI given HOMEPAGE also links to these and sourceforge release tarballs don't include 2.6.5 yet (if ever). Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/fceux/Manifest1
-rw-r--r--games-emulation/fceux/fceux-2.6.5.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/games-emulation/fceux/Manifest b/games-emulation/fceux/Manifest
index 39b635b3d0fe..f15c51a50550 100644
--- a/games-emulation/fceux/Manifest
+++ b/games-emulation/fceux/Manifest
@@ -1 +1,2 @@
DIST fceux-2.6.4.tar.gz 23372193 BLAKE2B 0a27bdc1637c4577f175f9afed6318d3020221a2823adc154baffbda005d28cfdf04a00bc0c7b3c9b51ec4b4f5a709e36cb686ec8f11c73f5e7c83e3b84b83e3 SHA512 9fd8b908b652b5b8f120d15bdd43fa1e3475a300e0f1ec7d44965c95ec4bf58f7f9fe9511ea975effaf37f2cc4900e74021b06111dcafecc27affdd9d4e12f2e
+DIST fceux-2.6.5.tar.gz 23299626 BLAKE2B 167fbe401635b96ad0c1c07826b1e7b032fa66806a2c395aebcae9d2b4295a327d2abad960a883751da43baf49f91276dd6521692406ce610df7c1ce167006ca SHA512 3d37583d1917783513f05bd215437401aacda3bd1930238212cbbdd6ba105236028066d7198bfd8182e6d55ded7ce293f1e5d23295d2b730ec800dc5e5652598
diff --git a/games-emulation/fceux/fceux-2.6.5.ebuild b/games-emulation/fceux/fceux-2.6.5.ebuild
new file mode 100644
index 000000000000..04832332f99f
--- /dev/null
+++ b/games-emulation/fceux/fceux-2.6.5.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( lua5-1 )
+inherit cmake lua-single xdg
+
+DESCRIPTION="Portable Famicom/NES emulator, an evolution of the original FCE Ultra"
+HOMEPAGE="https://fceux.com/"
+SRC_URI="https://github.com/TASEmulators/fceux/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ffmpeg qt6 x264 x265"
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+
+RDEPEND="
+ ${LUA_DEPS}
+ qt6? ( dev-qt/qtbase:6[gui,opengl,widgets,-gles2-only] )
+ !qt6? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtopengl:5[-gles2-only]
+ dev-qt/qtwidgets:5
+ )
+ media-libs/libglvnd
+ media-libs/libsdl2[joystick,sound,threads,video]
+ sys-libs/zlib:=[minizip]
+ ffmpeg? ( media-video/ffmpeg:= )
+ x264? ( media-libs/x264:= )
+ x265? ( media-libs/x265:= )"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.4.0-desktop.patch
+ "${FILESDIR}"/${PN}-2.4.0-no-git.patch
+)
+
+src_prepare() {
+ cmake_src_prepare
+
+ use x264 || sed -i '/pkg_check_modules.*X264/d' src/CMakeLists.txt || die
+ use x265 || sed -i '/pkg_check_modules.*X265/d' src/CMakeLists.txt || die
+ use ffmpeg || sed -i '/pkg_check_modules.*LIBAV/d' src/CMakeLists.txt || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DPUBLIC_RELEASE=yes
+ -DQT6=$(usex qt6)
+ )
+
+ cmake_src_configure
+}
+
+src_install() {
+ local DOCS=( README TODO-SDL changelog.txt documentation/. readme.md )
+ cmake_src_install
+
+ # remove unused/duplicate files
+ rm "${ED}"/usr/share/fceux/{lua5{1,.1}.dll,{fceux,taseditor}.chm} \
+ "${ED}"/usr/share/doc/${PF}/fceux{,-net-server}.6 \
+ "${ED}"/usr/share/man/man6/fceux-net-server.6 || die
+}