summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2020-08-07 00:33:04 +0300
committerMart Raudsepp <leio@gentoo.org>2020-08-07 00:38:25 +0300
commitf369403befe0faae5921e87debb9668eca55d25a (patch)
treea4220bc2ef4617508abb7eb95d9e06459b6f1009 /games-puzzle/lightsoff/lightsoff-3.36.0.ebuild
parentgames-board/gnome-mines: bump to 3.36.1 (diff)
downloadgentoo-f369403befe0faae5921e87debb9668eca55d25a.tar.gz
gentoo-f369403befe0faae5921e87debb9668eca55d25a.tar.bz2
gentoo-f369403befe0faae5921e87debb9668eca55d25a.zip
games-puzzle/lightsoff: bump to 3.36.0
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'games-puzzle/lightsoff/lightsoff-3.36.0.ebuild')
-rw-r--r--games-puzzle/lightsoff/lightsoff-3.36.0.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/games-puzzle/lightsoff/lightsoff-3.36.0.ebuild b/games-puzzle/lightsoff/lightsoff-3.36.0.ebuild
new file mode 100644
index 000000000000..346e932e9403
--- /dev/null
+++ b/games-puzzle/lightsoff/lightsoff-3.36.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+VALA_MIN_API_VERSION="0.40"
+inherit gnome.org gnome2-utils meson xdg vala
+
+DESCRIPTION="Turn off all the lights"
+HOMEPAGE="https://wiki.gnome.org/Apps/Lightsoff"
+
+LICENSE="GPL-2+ CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-libs/glib-2.38.0:2
+ >=x11-libs/gtk+-3.13.4:3
+ >=media-libs/clutter-1.14.0:1.0
+ >=media-libs/clutter-gtk-1.5.5:1.0
+ >=gnome-base/librsvg-2.32.0:2
+"
+DEPEND="${RDEPEND}"
+# libxml2:2 needed for glib-compile-resources xml-stripblanks attributes
+BDEPEND="
+ dev-libs/appstream-glib
+ dev-libs/libxml2:2
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ $(vala_depend)
+ gnome-base/librsvg:2[vala]
+"
+
+src_prepare() {
+ xdg_src_prepare
+ vala_src_prepare
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}