summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Reffett <creffett@gentoo.org>2016-07-30 16:29:37 -0400
committerChris Reffett <creffett@gentoo.org>2016-07-30 16:29:37 -0400
commitf22fcde397eaf46ea7d5f14b087c839766f64d1a (patch)
tree655842898b78e878ad34280151a4e52d70c365dc /games-roguelike/dwarf-fortress/files/Makefile.native
parentxfce-extra/xfce4-wavelan-plugin: Bump to 0.5.99, the GTK+3 pre-release (diff)
downloadgentoo-f22fcde397eaf46ea7d5f14b087c839766f64d1a.tar.gz
gentoo-f22fcde397eaf46ea7d5f14b087c839766f64d1a.tar.bz2
gentoo-f22fcde397eaf46ea7d5f14b087c839766f64d1a.zip
games-roguelike/dwarf-fortress: Version bump.
Gentoo-Bug: 589026 Package-Manager: portage-2.3.0_rc1 RepoMan-Options: --force
Diffstat (limited to 'games-roguelike/dwarf-fortress/files/Makefile.native')
-rw-r--r--games-roguelike/dwarf-fortress/files/Makefile.native28
1 files changed, 28 insertions, 0 deletions
diff --git a/games-roguelike/dwarf-fortress/files/Makefile.native b/games-roguelike/dwarf-fortress/files/Makefile.native
new file mode 100644
index 000000000000..85383e5e2f1d
--- /dev/null
+++ b/games-roguelike/dwarf-fortress/files/Makefile.native
@@ -0,0 +1,28 @@
+# Copyright 2014-2016 Alex Xu (Hello71)
+# Distributed under the terms of the GNU General Public License v2
+
+SRCS := g_src/basics.cpp g_src/command_line.cpp g_src/enabler.cpp \
+ g_src/files.cpp g_src/find_files_posix.cpp g_src/graphics.cpp \
+ g_src/init.cpp g_src/interface.cpp g_src/keybindings.cpp \
+ g_src/music_and_sound_openal.cpp g_src/random.cpp g_src/textlines.cpp \
+ g_src/enabler_input.cpp g_src/KeybindingScreen.cpp \
+ g_src/win32_compat.cpp g_src/textures.cpp g_src/resize++.cpp \
+ g_src/renderer_offscreen.cpp g_src/ttf_manager.cpp g_src/ViewBase.cpp
+OBJS := $(SRCS:.cpp=.o)
+
+BLIBS := ncursesw openal sndfile
+LIBS := glew glu gtk+-2.0 sdl SDL_image SDL_ttf zlib
+CXXFLAGS ?= -O2 -pipe -Wall -Wextra
+CXXFLAGS += $(shell $(PKG_CONFIG) --cflags $(BLIBS) $(LIBS)) -Dunix -Dlinux -fPIC -std=c++11 -D_GLIBCXX_USE_CXX11_ABI=0
+LDLIBS := $(shell $(PKG_CONFIG) --libs $(LIBS))
+
+LG := libs/libgraphics.so
+
+all: $(LG)
+$(LG): $(OBJS)
+ $(LINK.cpp) -shared $^ $(LDLIBS) -o $@
+
+clean:
+ $(RM) $(LG) $(OBJS)
+
+.PHONY: clean