summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>2024-07-19 19:33:46 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2024-07-20 14:22:23 +0300
commit8c6865a2b48617141ad8279024ccab9e0e764ad2 (patch)
treeaa0a6dda3990c52d0f971379841bdae437d25378 /games-rpg/xu4/files
parentgames-rpg/xu4: add 1.4 (diff)
downloadgentoo-8c6865a2b48617141ad8279024ccab9e0e764ad2.tar.gz
gentoo-8c6865a2b48617141ad8279024ccab9e0e764ad2.tar.bz2
gentoo-8c6865a2b48617141ad8279024ccab9e0e764ad2.zip
games-rpg/xu4: drop 1.2.1
Signed-off-by: Azamat H. Hackimov <azamat.hackimov@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/37620 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'games-rpg/xu4/files')
-rw-r--r--games-rpg/xu4/files/1.2.1-desktop-file.patch25
-rw-r--r--games-rpg/xu4/files/1.2.1-system-minizip.patch82
2 files changed, 0 insertions, 107 deletions
diff --git a/games-rpg/xu4/files/1.2.1-desktop-file.patch b/games-rpg/xu4/files/1.2.1-desktop-file.patch
deleted file mode 100644
index 442deb0971b3..000000000000
--- a/games-rpg/xu4/files/1.2.1-desktop-file.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From d5065c2c7f3b26bb21cb6d55bab8b0161c60b7d6 Mon Sep 17 00:00:00 2001
-From: "Azamat H. Hackimov" <azamat.hackimov@gmail.com>
-Date: Fri, 28 Apr 2023 20:42:37 +0300
-Subject: [PATCH] Update .desktop file
-
-Follow to Desktop Entry Specification.
-
-https://github.com/xu4-engine/u4/pull/15
-
---- a/dist/xu4.desktop
-+++ b/dist/xu4.desktop
-@@ -3,7 +3,7 @@ Encoding=UTF-8
- Name=Ultima 4
- Comment=Ultima 4 (xu4)
- Exec=xu4
--Icon=xu4.png
--Terminal=0
-+Icon=xu4
-+Terminal=false
- Type=Application
--Categories=Application;Game;RolePlaying;
-+Categories=Game;RolePlaying;
---
-2.39.2
-
diff --git a/games-rpg/xu4/files/1.2.1-system-minizip.patch b/games-rpg/xu4/files/1.2.1-system-minizip.patch
deleted file mode 100644
index 8466e27550c5..000000000000
--- a/games-rpg/xu4/files/1.2.1-system-minizip.patch
+++ /dev/null
@@ -1,82 +0,0 @@
-From bce27acd4063d43da601e0a7a85b35fab69cf4bd Mon Sep 17 00:00:00 2001
-From: "Azamat H. Hackimov" <azamat.hackimov@gmail.com>
-Date: Fri, 28 Apr 2023 16:30:40 +0300
-Subject: [PATCH] Switch to external zlib minizip library
-
-Bundled unzip.[ch] uses deprecated zlib macros and fails to compile.
-Additionaly added pkg-config calls to use system libraries and includes.
-
-https://github.com/xu4-engine/u4/pull/16
---- a/src/Makefile
-+++ b/src/Makefile
-@@ -8,11 +8,13 @@ UI ?= glv
- GPU ?= scale
- SOUND=faun
-
-+PKG_CONFIG ?= pkg-config
-+
- ifeq ($(UI), allegro)
- ifeq ($(SOUND),allegro)
-- UILIBS=-lallegro_acodec -lallegro_audio -lallegro
-+ UILIBS=$(shell ${PKG_CONFIG} --libs allegro-5 allegro_acodec-5 allegro_audio-5)
- else
-- UILIBS=-lallegro
-+ UILIBS=$(shell ${PKG_CONFIG} --libs allegro-5)
- endif
- endif
-
-@@ -37,23 +39,25 @@ endif
- UILIBS+=-lboron
- #endif
-
--CXXFLAGS=-Wall -I. -Isupport $(UIFLAGS) -DVERSION=\"$(VERSION)\"
-+CXXFLAGS+=-Wall -I. -Isupport $(UIFLAGS) -DVERSION=\"$(VERSION)\"
- #CXXFLAGS+=-rdynamic -DHAVE_BACKTRACE=1 -DHAVE_VARIADIC_MACROS=1
-
- # Choose one of these for debug/release mode.
- #CXXFLAGS+=-g -DDEBUG
- CXXFLAGS+=-O3 -DNDEBUG
-
-+CXXFLAGS+=$(shell ${PKG_CONFIG} --cflags minizip)
-+
- ifeq ($(UI), glv)
- CXXFLAGS+=-Iglv/x11
- GLV_SRC=glv/x11/glv.c
--UILIBS+=-lXcursor -lX11
-+UILIBS+=$(shell ${PKG_CONFIG} --libs xcursor x11)
- CFLAGS=$(CXXFLAGS) -DUSE_CURSORS
- else
- CFLAGS=$(CXXFLAGS)
- endif
-
--LIBS=$(UILIBS) -lGL -lpng -lz
-+LIBS=$(UILIBS) $(shell ${PKG_CONFIG} --libs gl libpng minizip zlib)
-
- ifeq ($(STATIC_GCC_LIBS),true)
- LDFLAGS+=-L. -static-libgcc
---- a/src/Makefile.common
-+++ b/src/Makefile.common
-@@ -9,7 +9,6 @@ CSRCS=\
- support/notify.c \
- support/stringTable.c \
- support/txf_draw.c \
-- unzip.c \
- $(NULL)
-
- CXXSRCS=\
---- a/src/u4file.cpp
-+++ b/src/u4file.cpp
-@@ -6,9 +6,9 @@
- #include <cctype>
- #include <cstring>
- #include <cstdlib>
-+#include <unzip.h>
-
- #include "u4file.h"
--#include "unzip.h"
- #include "debug.h"
- #include "xu4.h"
-
---
-2.39.2
-