summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-11-23 00:01:36 +0100
committerMichał Górny <mgorny@gentoo.org>2020-11-23 01:33:31 +0100
commit8024a7110d1b7b6e05a6bbf818f59fdc07f0e929 (patch)
treed498243d06eb59662c024eae73fdfc9d21daa2c4 /games-strategy/war1gus
parentgames-strategy/wargus: Add postinst about missing ripping deps (diff)
downloadgentoo-8024a7110d1b7b6e05a6bbf818f59fdc07f0e929.tar.gz
gentoo-8024a7110d1b7b6e05a6bbf818f59fdc07f0e929.tar.bz2
gentoo-8024a7110d1b7b6e05a6bbf818f59fdc07f0e929.zip
games-strategy/war1gus: New package
This is the Stratagus version of the first Warcraft (AKA Orcs & Humans). Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'games-strategy/war1gus')
-rw-r--r--games-strategy/war1gus/Manifest1
-rw-r--r--games-strategy/war1gus/metadata.xml11
-rw-r--r--games-strategy/war1gus/war1gus-2.4.3.ebuild60
3 files changed, 72 insertions, 0 deletions
diff --git a/games-strategy/war1gus/Manifest b/games-strategy/war1gus/Manifest
new file mode 100644
index 000000000000..3e030e66acef
--- /dev/null
+++ b/games-strategy/war1gus/Manifest
@@ -0,0 +1 @@
+DIST war1gus-2.4.3.tar.gz 436938 BLAKE2B 662c3e2d16d4ca3225a50ec28ff6ae11f9c309a02c1b71e26a28155012395091dec7833a4f32a0ee6c19119a9c0aa2aa96cb465b06937da8efdd54b040189778 SHA512 909dc3375a00a4ff05eb287e6a1e3414b084f51cda37fe73ab4d728eb2d13e3e0e8612700a90e000d67a9ddffb115fe41554a4ad9db9f68e0b62cdbc0d025ae0
diff --git a/games-strategy/war1gus/metadata.xml b/games-strategy/war1gus/metadata.xml
new file mode 100644
index 000000000000..98971eeec5c4
--- /dev/null
+++ b/games-strategy/war1gus/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">Wargus/war1gus</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-strategy/war1gus/war1gus-2.4.3.ebuild b/games-strategy/war1gus/war1gus-2.4.3.ebuild
new file mode 100644
index 000000000000..7871af95da19
--- /dev/null
+++ b/games-strategy/war1gus/war1gus-2.4.3.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake xdg-utils
+
+DESCRIPTION="Warcraft: Orcs & Humans for the Stratagus game engine"
+HOMEPAGE="https://wargus.github.io/war1gus.html
+ https://github.com/Wargus/war1gus"
+SRC_URI="https://github.com/Wargus/war1gus/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ =games-engines/stratagus-${PV}*[theora]
+ media-libs/libpng:0=
+ sys-libs/zlib:=
+ x11-libs/gtk+:2
+ x11-libs/libX11"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig"
+
+src_configure() {
+ local mycmakeargs=(
+ -DGAMEDIR="${EPREFIX}/usr/bin"
+ -DBINDIR="${EPREFIX}/usr/bin"
+ -DSTRATAGUS="${EPREFIX}/usr/bin/stratagus"
+ -DSHAREDIR="${EPREFIX}/usr/share/stratagus/war1gus"
+ -DICONDIR=/usr/share/icons/hicolor/64x64/apps
+ )
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ elog "War1gus requires the data from the original game to run. The game"
+ elog "will ask you for the location of the game data and extract/convert"
+ elog "it automatically on the first run."
+
+ if ! has_version media-video/ffmpeg ||
+ ! has_version media-sound/timidity++
+ then
+ elog
+ elog "If you did not convert the game data yet, you may want to install"
+ elog "the following optional dependencies:"
+ elog
+ elog "media-video/ffmpeg -- to convert game videos"
+ elog "media-sound/timidity++ -- to convert game music"
+ fi
+
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}