summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2023-08-24 16:32:23 +0200
committerPacho Ramos <pacho@gentoo.org>2023-08-24 16:35:07 +0200
commit71e03c5df298be999546115390312bb25314bef0 (patch)
treecb74cb76876de343a74d6529ffb491cf5e60d6fe /games-strategy
parentgui-apps/wl-clipboard: stabilize 2.2.0 for amd64, arm64, x86 (diff)
downloadgentoo-71e03c5df298be999546115390312bb25314bef0.tar.gz
gentoo-71e03c5df298be999546115390312bb25314bef0.tar.bz2
gentoo-71e03c5df298be999546115390312bb25314bef0.zip
games-strategy/wesnoth: Apply patch fixing boost-1.83 compat
Thanks-to: solpeth Closes: https://github.com/gentoo/gentoo/pull/32415 Closes: https://bugs.gentoo.org/912385 Closes: https://bugs.gentoo.org/912968 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/wesnoth/files/wesnoth-1.16.10-boost-1.83.patch26
-rw-r--r--games-strategy/wesnoth/wesnoth-1.16.10.ebuild4
2 files changed, 30 insertions, 0 deletions
diff --git a/games-strategy/wesnoth/files/wesnoth-1.16.10-boost-1.83.patch b/games-strategy/wesnoth/files/wesnoth-1.16.10-boost-1.83.patch
new file mode 100644
index 000000000000..2c9e55db0472
--- /dev/null
+++ b/games-strategy/wesnoth/files/wesnoth-1.16.10-boost-1.83.patch
@@ -0,0 +1,26 @@
+From 136e651d69fc91fa7a4154f8a4a7e977cc46eca4 Mon Sep 17 00:00:00 2001
+From: Pentarctagon <pentarctagon@tutamail.com>
+Date: Thu, 17 Aug 2023 23:19:21 -0500
+Subject: [PATCH] Compile fix for boost 1.83.
+
+Fixes #7849
+---
+ src/gettext.cpp | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/src/gettext.cpp b/src/gettext.cpp
+index 9888dede35ad..fa9b17ba85b2 100644
+--- a/src/gettext.cpp
++++ b/src/gettext.cpp
+@@ -169,7 +169,11 @@ namespace
+ return msg;
+ }
+
++#if BOOST_VERSION < 108300
+ const char* get(int domain_id, const char* ctx, const char* sid, int n) const override
++#else
++ const char* get(int domain_id, const char* ctx, const char* sid, bl::count_type n) const override
++#endif
+ {
+ auto& base = get_base();
+ const char* msg = base.get(domain_id, ctx, sid, n);
diff --git a/games-strategy/wesnoth/wesnoth-1.16.10.ebuild b/games-strategy/wesnoth/wesnoth-1.16.10.ebuild
index d3d826ea899c..cb9bc76bf65d 100644
--- a/games-strategy/wesnoth/wesnoth-1.16.10.ebuild
+++ b/games-strategy/wesnoth/wesnoth-1.16.10.ebuild
@@ -43,6 +43,10 @@ BDEPEND="
virtual/pkgconfig
"
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.16.10-boost-1.83.patch #912385
+)
+
src_prepare() {
cmake_src_prepare