summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-10-17 09:57:58 +0200
committerLars Wendler <polynomial-c@gentoo.org>2016-10-17 11:04:20 +0200
commit4bd158c8fcf38d600930b36d90dd8afebf130e51 (patch)
treec298df4ee8ac25465090d9b695448d80f9a98477 /games-util/joystick/joystick-1.6.0.ebuild
parentnet-misc/nextcloud-client: version bump to 2.2.4, bug #597104 (diff)
downloadgentoo-4bd158c8fcf38d600930b36d90dd8afebf130e51.tar.gz
gentoo-4bd158c8fcf38d600930b36d90dd8afebf130e51.tar.bz2
gentoo-4bd158c8fcf38d600930b36d90dd8afebf130e51.zip
games-util/joystick: Bump to version 1.6.0
Package-Manager: portage-2.3.2 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'games-util/joystick/joystick-1.6.0.ebuild')
-rw-r--r--games-util/joystick/joystick-1.6.0.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/games-util/joystick/joystick-1.6.0.ebuild b/games-util/joystick/joystick-1.6.0.ebuild
new file mode 100644
index 000000000000..7ce51eda084b
--- /dev/null
+++ b/games-util/joystick/joystick-1.6.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils toolchain-funcs
+
+MY_P="linuxconsoletools-${PV}"
+DESCRIPTION="joystick testing utilities"
+HOMEPAGE="https://sourceforge.net/projects/linuxconsole/ http://atrey.karlin.mff.cuni.cz/~vojtech/input/"
+SRC_URI="mirror://sourceforge/linuxconsole/files/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+IUSE="sdl udev"
+
+DEPEND="sdl? ( media-libs/libsdl:0[video] )
+ !<x11-libs/tslib-1.0-r2"
+RDEPEND="${DEPEND}
+ udev? ( virtual/udev )"
+
+S=${WORKDIR}/${MY_P}
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.6.0-build.patch
+ "${FILESDIR}"/${PN}-1.4.8-udev.patch
+)
+
+src_prepare() {
+ default
+
+ export PREFIX=/usr
+ tc-export CC PKG_CONFIG
+ export USE_SDL=$(usex sdl)
+}
+
+src_install() {
+ default
+ if use !udev ; then
+ rm "${D}"/usr/bin/jscal-{re,}store || die
+ fi
+}