summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2024-08-13 18:24:39 +0200
committerJames Le Cuirot <chewi@gentoo.org>2024-08-15 21:31:26 +0100
commit828493214d6cb998dc3fee7203e58ffa571eb629 (patch)
tree0aef62059156af33e018d2953b35f9f5e15890c5 /games-util
parentsci-libs/pdal: bump 2.7.2 (diff)
downloadgentoo-828493214d6cb998dc3fee7203e58ffa571eb629.tar.gz
gentoo-828493214d6cb998dc3fee7203e58ffa571eb629.tar.bz2
gentoo-828493214d6cb998dc3fee7203e58ffa571eb629.zip
games-util/sc-controller: add 0.4.8.17
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Closes: https://github.com/gentoo/gentoo/pull/38135 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'games-util')
-rw-r--r--games-util/sc-controller/Manifest1
-rw-r--r--games-util/sc-controller/sc-controller-0.4.8.17.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/games-util/sc-controller/Manifest b/games-util/sc-controller/Manifest
index 476ec7fe3f13..63b673f9bffb 100644
--- a/games-util/sc-controller/Manifest
+++ b/games-util/sc-controller/Manifest
@@ -1 +1,2 @@
DIST sc-controller-0.4.8.16.tar.gz 2570556 BLAKE2B 2aafad5eeb05d0525646bc1c5c08659dc09eba764bca84c0bb25524883b40d9dc8aa26981c6aeab834e429f0211bb97da902e15433876187a3c5b22d61fe8391 SHA512 3e37049b91ff927f047b3518b0c8382875d6faf748fac842c6b3276fb327953e4b1c20ce83ec80baa2b5338d6262aa32ac7dcf6b924c886984564de97e1d8177
+DIST sc-controller-0.4.8.17.tar.gz 1843813 BLAKE2B 77925152086d516be2b67eee70c36fad7fc6ccfb829196cf433331cce7a5ac43e22a466a7929c2ba2504fcb8ac73a62458be9be77162e138e4abad238e9cf2c1 SHA512 5121a802a719357027e1e850250182b2ace77966938f4add6f2f4a5b91fa768e2ef9064c8bb087c2df0979f34f68b5054e3d8d359ceff71f7ecadc3a51f92dae
diff --git a/games-util/sc-controller/sc-controller-0.4.8.17.ebuild b/games-util/sc-controller/sc-controller-0.4.8.17.ebuild
new file mode 100644
index 000000000000..05c53bdb4a47
--- /dev/null
+++ b/games-util/sc-controller/sc-controller-0.4.8.17.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+inherit distutils-r1 linux-info xdg
+
+DESCRIPTION="User-mode driver and GTK-based GUI for Steam Controllers and others"
+HOMEPAGE="https://github.com/C0rn3j/sc-controller/"
+SRC_URI="https://github.com/C0rn3j/sc-controller/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2 BSD CC-BY-3.0 CC0-1.0 LGPL-2.1 MIT PSF-2 ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+udev wayland"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/evdev[${PYTHON_USEDEP}]
+ dev-python/pygobject[${PYTHON_USEDEP},cairo]
+ dev-python/pylibacl[${PYTHON_USEDEP}]
+ dev-python/vdf[${PYTHON_USEDEP}]
+ ')
+ gnome-base/librsvg[introspection]
+ virtual/libusb
+ x11-libs/gtk+:3[introspection]
+ udev? ( games-util/game-device-udev-rules )
+ wayland? ( gui-libs/gtk-layer-shell[introspection(+)] )
+"
+
+distutils_enable_tests pytest
+
+pkg_setup() {
+ local CONFIG_CHECK="~INPUT_UINPUT"
+
+ linux-info_pkg_setup
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ # This test fails. Don't know why but seems unimportant.
+ rm -v tests/test_glade.py || die
+}
+
+src_install() {
+ distutils-r1_src_install
+ rm -r "${ED}"/usr/lib/udev/ || die
+}