summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /gnome-base/gnome-common
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'gnome-base/gnome-common')
-rw-r--r--gnome-base/gnome-common/Manifest2
-rw-r--r--gnome-base/gnome-common/gnome-common-3.12.0.ebuild21
-rw-r--r--gnome-base/gnome-common/gnome-common-3.14.0-r1.ebuild30
-rw-r--r--gnome-base/gnome-common/gnome-common-3.14.0.ebuild24
-rw-r--r--gnome-base/gnome-common/metadata.xml9
5 files changed, 86 insertions, 0 deletions
diff --git a/gnome-base/gnome-common/Manifest b/gnome-base/gnome-common/Manifest
new file mode 100644
index 000000000000..ef21b5dba1a1
--- /dev/null
+++ b/gnome-base/gnome-common/Manifest
@@ -0,0 +1,2 @@
+DIST gnome-common-3.12.0.tar.xz 153060 SHA256 18712bc2df6b2dd88a11b9f7f874096d1c0c6e7ebc9cfc0686ef963bd590e1d8 SHA512 997e6cd4e3d92f02adc24f001479488ef18d46a432b0ebb740635eafa5bbe9fd5377553e944489bc9d70b83156a07bc20429ccc8a5b3b0acb60107bbc1cc3b2c WHIRLPOOL 7ab7bd709dff5d992677015d4e7f09963575b3ab8a2086d1962d7bf30be8a4bbf6a54569c64029d4ca465186b70a3274ab8d63cca2e8a54dbd3a08ca1189a144
+DIST gnome-common-3.14.0.tar.xz 156320 SHA256 4c00242f781bb441289f49dd80ed1d895d84de0c94bfc2c6818a104c9e39262c SHA512 19f00278827fcd7f81a2ea7c198bd270b58f5308f2bb1857f59151c9743c3d968c3f8a7c9885a1b3d50e0e60719b835b0ec2dfc64cc76f00df7b1856822dd695 WHIRLPOOL fa9c553ed816dfa6b72a52d052c839eb626ef68ae306b8647e0ca8db84d44653c922b85ddb258d98af96755693ab0ef1d175654a201884cb2e19add56621855a
diff --git a/gnome-base/gnome-common/gnome-common-3.12.0.ebuild b/gnome-base/gnome-common/gnome-common-3.12.0.ebuild
new file mode 100644
index 000000000000..d7a61e85ddaf
--- /dev/null
+++ b/gnome-base/gnome-common/gnome-common-3.12.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit gnome.org
+
+DESCRIPTION="Common files for development of Gnome packages"
+HOMEPAGE="http://git.gnome.org/browse/gnome-common"
+
+LICENSE="GPL-3"
+SLOT="3"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+src_install() {
+ default
+ mv doc-build/README README.doc-build || die "renaming doc-build/README failed"
+ dodoc ChangeLog README* doc/usage.txt
+}
diff --git a/gnome-base/gnome-common/gnome-common-3.14.0-r1.ebuild b/gnome-base/gnome-common/gnome-common-3.14.0-r1.ebuild
new file mode 100644
index 000000000000..b4a2306fac87
--- /dev/null
+++ b/gnome-base/gnome-common/gnome-common-3.14.0-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit gnome.org
+
+DESCRIPTION="Common files for development of Gnome packages"
+HOMEPAGE="http://git.gnome.org/browse/gnome-common"
+
+LICENSE="GPL-3"
+SLOT="3"
+KEYWORDS="alpha amd64 arm ~arm64 ~hppa ~ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="+autoconf-archive"
+
+RDEPEND="autoconf-archive? ( >=sys-devel/autoconf-archive-2015.02.04 )
+ !autoconf-archive? ( !>=sys-devel/autoconf-archive-2015.02.04 )
+"
+DEPEND=""
+
+src_install() {
+ default
+ if use autoconf-archive; then
+ # do not install macros owned by autoconf-archive, bug #540138
+ rm "${ED}"/usr/share/aclocal/ax_{check_enable_debug,code_coverage}.m4 || die "removing macros failed"
+ fi
+ mv doc-build/README README.doc-build || die "renaming doc-build/README failed"
+ dodoc ChangeLog README*
+}
diff --git a/gnome-base/gnome-common/gnome-common-3.14.0.ebuild b/gnome-base/gnome-common/gnome-common-3.14.0.ebuild
new file mode 100644
index 000000000000..33f77dfd75e2
--- /dev/null
+++ b/gnome-base/gnome-common/gnome-common-3.14.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit gnome.org
+
+DESCRIPTION="Common files for development of Gnome packages"
+HOMEPAGE="http://git.gnome.org/browse/gnome-common"
+
+LICENSE="GPL-3"
+SLOT="3"
+KEYWORDS="~alpha amd64 arm ~arm64 hppa ~ia64 ~mips ppc ppc64 ~s390 ~sh ~sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="!>=sys-devel/autoconf-archive-2015.02.04"
+DEPEND=""
+
+src_install() {
+ default
+ mv doc-build/README README.doc-build || die "renaming doc-build/README failed"
+ dodoc ChangeLog README*
+}
diff --git a/gnome-base/gnome-common/metadata.xml b/gnome-base/gnome-common/metadata.xml
new file mode 100644
index 000000000000..4a4731d98a3f
--- /dev/null
+++ b/gnome-base/gnome-common/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnome</herd>
+<use>
+ <flag name="autoconf-archive">Pull in <pkg>sys-devel/autoconf-archive</pkg> for ax_*.m4 files
+ instead of installing them from the gnome-common tarball</flag>
+</use>
+</pkgmetadata>