summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAliaksei Urbanski <aliaksei.urbanski@gmail.com>2024-02-06 01:44:04 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2024-02-07 12:01:25 +0200
commit52df57a4f1e92549962c503693ce9a8b40588603 (patch)
treedeb78a2c1e57967ad5057ce3f29d100d35e709aa /gui-apps
parentdev-python/spyder: add 5.5.1 (diff)
downloadgentoo-52df57a4f1e92549962c503693ce9a8b40588603.tar.gz
gentoo-52df57a4f1e92549962c503693ce9a8b40588603.tar.bz2
gentoo-52df57a4f1e92549962c503693ce9a8b40588603.zip
gui-apps/wf-recorder: add 0.4.1
Corresponding release: - https://github.com/ammen99/wf-recorder/releases/tag/v0.4.1 These changes also add the pulseaudio USE flag. Closes: https://bugs.gentoo.org/871684 Signed-off-by: Aliaksei Urbanski <aliaksei.urbanski@gmail.com> Co-authored-by: Arthur Zamarin <arthurzam@gentoo.org> Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/35161 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'gui-apps')
-rw-r--r--gui-apps/wf-recorder/Manifest1
-rw-r--r--gui-apps/wf-recorder/metadata.xml3
-rw-r--r--gui-apps/wf-recorder/wf-recorder-0.4.1.ebuild41
-rw-r--r--gui-apps/wf-recorder/wf-recorder-9999.ebuild15
4 files changed, 57 insertions, 3 deletions
diff --git a/gui-apps/wf-recorder/Manifest b/gui-apps/wf-recorder/Manifest
index 4a8da3a7e14b..6a86d06fdba2 100644
--- a/gui-apps/wf-recorder/Manifest
+++ b/gui-apps/wf-recorder/Manifest
@@ -1 +1,2 @@
DIST wf-recorder-0.3.0.tar.xz 19888 BLAKE2B 52b7cbe8ad77d3756f91cad0c0642548b439f3465be8152d9cc1175f55d608df8bbd9f21e82b18099fba59d39389012e023e7dc39a0ae061eed13aece99c058a SHA512 6c8a069c923a342441ab5ebce2cf8ec727b75f474c2843d0fa49b69b3e5ef4498bc0548573409203e704a84a72ebec5523f89459a144679bf1d9d5bf6e514b60
+DIST wf-recorder-0.4.1.tar.xz 26184 BLAKE2B 87110d3fb8629b5cdfc2c4b50da56d19630b97ffb7e46a555099c8fca263bd1bd87fb03a497fbb5e5ac0022b31bb5c93dc4ea29785de33dd7f2adc8db74f7db2 SHA512 c97b3a0570aa5496d93b88549db6cd682e80c1497bbd6e999ab6b35f2f13adc7af167c22517fa35eab5d3021439001d0e7cfe2ee75a2ba99b9aa6953beb56aa0
diff --git a/gui-apps/wf-recorder/metadata.xml b/gui-apps/wf-recorder/metadata.xml
index fdda02a176cb..c918bd848a21 100644
--- a/gui-apps/wf-recorder/metadata.xml
+++ b/gui-apps/wf-recorder/metadata.xml
@@ -5,4 +5,7 @@
<upstream>
<remote-id type="github">ammen99/wf-recorder</remote-id>
</upstream>
+ <use>
+ <flag name="pulseaudio">Enable support for audio capture via PulseAudio</flag>
+ </use>
</pkgmetadata>
diff --git a/gui-apps/wf-recorder/wf-recorder-0.4.1.ebuild b/gui-apps/wf-recorder/wf-recorder-0.4.1.ebuild
new file mode 100644
index 000000000000..3a7ded597607
--- /dev/null
+++ b/gui-apps/wf-recorder/wf-recorder-0.4.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="Screen recorder for wlroots-based compositors"
+HOMEPAGE="https://github.com/ammen99/wf-recorder"
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ammen99/wf-recorder.git"
+else
+ SRC_URI="https://github.com/ammen99/wf-recorder/releases/download/v${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="pulseaudio"
+
+DEPEND="
+ dev-libs/wayland
+ media-libs/mesa[wayland]
+ media-video/ffmpeg[pulseaudio?,x264]
+ pulseaudio? ( media-libs/libpulse )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ dev-libs/wayland-protocols
+ dev-util/wayland-scanner
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature pulseaudio pulse)
+ )
+ meson_src_configure
+}
diff --git a/gui-apps/wf-recorder/wf-recorder-9999.ebuild b/gui-apps/wf-recorder/wf-recorder-9999.ebuild
index fd58d11409c9..3a7ded597607 100644
--- a/gui-apps/wf-recorder/wf-recorder-9999.ebuild
+++ b/gui-apps/wf-recorder/wf-recorder-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2020-2023 Gentoo Authors
+# Copyright 2020-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -18,11 +18,13 @@ fi
LICENSE="MIT"
SLOT="0"
+IUSE="pulseaudio"
DEPEND="
dev-libs/wayland
- media-libs/libpulse
- media-video/ffmpeg[pulseaudio,x264]
+ media-libs/mesa[wayland]
+ media-video/ffmpeg[pulseaudio?,x264]
+ pulseaudio? ( media-libs/libpulse )
"
RDEPEND="${DEPEND}"
BDEPEND="
@@ -30,3 +32,10 @@ BDEPEND="
dev-util/wayland-scanner
virtual/pkgconfig
"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature pulseaudio pulse)
+ )
+ meson_src_configure
+}