summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-12-03 20:29:31 -0500
committerMatt Turner <mattst88@gentoo.org>2022-12-03 21:37:01 -0500
commit3d3c5dcf83679ce538a2e7111358d8e05c739770 (patch)
treed1e68298cc660bed06529b7c1d1d6e26c6d037c7 /gui-libs
parentgui-libs/libwpe: Drop old versions (diff)
downloadgentoo-3d3c5dcf83679ce538a2e7111358d8e05c739770.tar.gz
gentoo-3d3c5dcf83679ce538a2e7111358d8e05c739770.tar.bz2
gentoo-3d3c5dcf83679ce538a2e7111358d8e05c739770.zip
gui-libs/vte-common: Drop old versions
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'gui-libs')
-rw-r--r--gui-libs/vte-common/Manifest1
-rw-r--r--gui-libs/vte-common/vte-common-0.70.0.ebuild78
2 files changed, 0 insertions, 79 deletions
diff --git a/gui-libs/vte-common/Manifest b/gui-libs/vte-common/Manifest
index 08d1f5f0f4f3..a3e8c8e31bb4 100644
--- a/gui-libs/vte-common/Manifest
+++ b/gui-libs/vte-common/Manifest
@@ -1,3 +1,2 @@
-DIST vte-0.70.0.tar.bz2 499283 BLAKE2B 694cf4dfee334e9b54bb8e47f862167acbb8ffc7ac8e81889acd4786449cb45944a87a5adaa036f46458c350ca2119bb356e90dfa71f03638c9c2b14d2ccb877 SHA512 362b71296ae39a16b55402f524a39b063f66ae237e6e161ccc89ca2bb1f2a5c43f4d706d9f3bfae12a99fdb81c4e70408c7f3eca2c01316950b0a3a1a1d79423
DIST vte-0.70.1.tar.bz2 502044 BLAKE2B 0a9ce43c1863e823fcd073fd30fb6b2cb39e9168e850796fe12be2b9bdfc0b24ceea974b4c94bcdd10f2225613990e0e079194380241b7e625cb6dc4309a7476 SHA512 88de629b382eca8a42199b2ba9b248e231817e1de7183417aed150bcf61530084f7177d73dee9aab25fe4c3ab80d795b5fdcae336687560d3b582bd04181353d
DIST vte-0.70.2.tar.bz2 502395 BLAKE2B ae127d8262c7038b3a2cda9a9622e9a075dfc1e06a7710810a4bb894a6646155790776553f663677cb86c3479e6d3faf92c38b5b97dd6970df37cee92dd963fa SHA512 1e113da0591830c057358dd78cfe2f814dd0bfabd037973369266823a9a4936a200b5b23faab3757ced4d08aa96a76d6b1120419815a181598493e35d2ea58d0
diff --git a/gui-libs/vte-common/vte-common-0.70.0.ebuild b/gui-libs/vte-common/vte-common-0.70.0.ebuild
deleted file mode 100644
index 23bef45e9c29..000000000000
--- a/gui-libs/vte-common/vte-common-0.70.0.ebuild
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-PYTHON_COMPAT=( python3_{8..11} )
-
-inherit gnome.org meson python-any-r1
-
-DESCRIPTION="Library providing a virtual terminal emulator widget"
-HOMEPAGE="https://wiki.gnome.org/Apps/Terminal/VTE https://gitlab.gnome.org/GNOME/vte"
-
-# Once SIXEL support ships (0.66 or later), might need xterm license (but code might be considered upgraded to LGPL-3+)
-LICENSE="LGPL-3+ GPL-3+"
-SLOT="2.91" # vte_api_version in meson.build
-IUSE="systemd"
-KEYWORDS="~amd64"
-
-# Upstream is hostile and refuses to upload tarballs.
-SRC_URI="https://gitlab.gnome.org/GNOME/vte/-/archive/${PV}/vte-${PV}.tar.bz2"
-
-DEPEND="
- || ( >=gui-libs/gtk-4.0.1:4 >=x11-libs/gtk+-3.24.22:3 )
- >=dev-libs/fribidi-1.0.0
- >=dev-libs/glib-2.52:2
- >=x11-libs/pango-1.22.0
- >=dev-libs/libpcre2-10.21
- systemd? ( >=sys-apps/systemd-220:= )
- sys-libs/zlib
- x11-libs/pango
-"
-RDEPEND="
- !<x11-libs/vte-0.70.0
-"
-BDEPEND="
- ${PYTHON_DEPS}
- dev-libs/libxml2:2
- dev-util/glib-utils
- >=sys-devel/gettext-0.19.8
- virtual/pkgconfig
-"
-
-S="${WORKDIR}/vte-0.70.0"
-
-src_prepare() {
- default
- use elibc_musl && eapply "${FILESDIR}"/${PN}-0.70.0-musl-W_EXITCODE.patch
-}
-
-src_configure() {
- local emesonargs=(
- -Da11y=false
- -Ddebugg=false
- -Ddocs=false
- -Dgir=false
- -Dfribidi=true # pulled in by pango anyhow
- -Dglade=false
- -Dgnutls=false
- -Dgtk3=false
- -Dgtk4=false
- -Dicu=false
- $(meson_use systemd _systemd)
- -Dvapi=false
- )
- meson_src_configure
-}
-
-src_install() {
- exeinto /usr/libexec/
- doexe "${BUILD_DIR}"/src/vte-urlencode-cwd
- insinto /etc/profile.d/
- newins "${BUILD_DIR}"/src/vte.sh vte-${SLOT}.sh
- newins "${BUILD_DIR}"/src/vte.csh vte-${SLOT}.csh
- if use systemd; then
- insinto /usr/lib/systemd/user/vte-spawn-.scode.d/
- newins "${S}"/src/vte-spawn-.scope.conf defaults.conf
- fi
- einstalldocs
-}