summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-08-20 17:34:55 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2024-08-21 23:16:32 +0200
commit310c5c3f097f448ff5d5d21f6b137e14081f326e (patch)
tree66c8a86e5edabcb686652d3bdd05b0fc77e1714c /kde-apps/calendarjanitor
parentkde-apps/kdecore-meta: drop 23.08.5, 24.05.2 (diff)
downloadgentoo-310c5c3f097f448ff5d5d21f6b137e14081f326e.tar.gz
gentoo-310c5c3f097f448ff5d5d21f6b137e14081f326e.tar.bz2
gentoo-310c5c3f097f448ff5d5d21f6b137e14081f326e.zip
kde-apps/calendarjanitor: Set ECM_HANDBOOK="forceoff"
There is no handbook for this package, so there should be no IUSE. Also, do not install an empty logging categories file. Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/calendarjanitor')
-rw-r--r--kde-apps/calendarjanitor/calendarjanitor-24.05.2-r1.ebuild41
-rw-r--r--kde-apps/calendarjanitor/files/calendarjanitor-24.05.2-loggingcategory.patch50
2 files changed, 91 insertions, 0 deletions
diff --git a/kde-apps/calendarjanitor/calendarjanitor-24.05.2-r1.ebuild b/kde-apps/calendarjanitor/calendarjanitor-24.05.2-r1.ebuild
new file mode 100644
index 000000000000..cc8cce8da0e1
--- /dev/null
+++ b/kde-apps/calendarjanitor/calendarjanitor-24.05.2-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_HANDBOOK="forceoff"
+ECM_TEST="false"
+KDE_ORG_NAME="akonadi-calendar-tools"
+PVCUT=$(ver_cut 1-3)
+KFMIN=6.3.0
+QTMIN=6.6.2
+inherit ecm gear.kde.org
+
+DESCRIPTION="Tool to scan calendar data for buggy instances"
+
+LICENSE="GPL-2+"
+SLOT="6"
+KEYWORDS="~amd64 ~arm64"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtbase-${QTMIN}:6[widgets]
+ >=kde-apps/akonadi-${PVCUT}:6
+ >=kde-apps/akonadi-calendar-${PVCUT}:6
+ >=kde-apps/calendarsupport-${PVCUT}:6
+ >=kde-frameworks/kcalendarcore-${KFMIN}:6
+ >=kde-frameworks/kcoreaddons-${KFMIN}:6
+ >=kde-frameworks/ki18n-${KFMIN}:6
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}-loggingcategory.patch" )
+
+src_prepare() {
+ ecm_src_prepare
+ cmake_comment_add_subdirectory doc konsolekalendar
+
+ # delete colliding konsolekalendar translations
+ rm -f po/*/konsolekalendar.po || die
+ rm -rf po/*/docs/konsolekalendar || die
+}
diff --git a/kde-apps/calendarjanitor/files/calendarjanitor-24.05.2-loggingcategory.patch b/kde-apps/calendarjanitor/files/calendarjanitor-24.05.2-loggingcategory.patch
new file mode 100644
index 000000000000..e9796c334280
--- /dev/null
+++ b/kde-apps/calendarjanitor/files/calendarjanitor-24.05.2-loggingcategory.patch
@@ -0,0 +1,50 @@
+From 1c10a1418a063d625dce2fc1a5714b82f9cee728 Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Mon, 12 Aug 2024 16:02:27 +0200
+Subject: [PATCH] Move ecm_qt_install_logging_categories to konsolekalendar
+ subdir
+
+None is declared in calendarjanitor.
+
+Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
+---
+ CMakeLists.txt | 6 ------
+ konsolekalendar/CMakeLists.txt | 5 +++++
+ 2 files changed, 5 insertions(+), 6 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index d887d81..f79b923 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -79,12 +79,6 @@ endif()
+ add_subdirectory(calendarjanitor)
+ add_subdirectory(konsolekalendar)
+
+-ecm_qt_install_logging_categories(
+- EXPORT AKONADICALENDARTOOLS
+- FILE console.categories
+- DESTINATION ${KDE_INSTALL_LOGGINGCATEGORIESDIR}
+- )
+-
+ add_subdirectory(doc)
+ kde_configure_git_pre_commit_hook(CHECKS CLANG_FORMAT)
+ ki18n_install(po)
+diff --git a/konsolekalendar/CMakeLists.txt b/konsolekalendar/CMakeLists.txt
+index c0b0eab..7e90f6c 100644
+--- a/konsolekalendar/CMakeLists.txt
++++ b/konsolekalendar/CMakeLists.txt
+@@ -44,6 +44,11 @@ target_link_libraries(konsolekalendar
+
+ install(TARGETS konsolekalendar ${KDE_INSTALL_TARGETS_DEFAULT_ARGS})
+
++ecm_qt_install_logging_categories(
++ EXPORT AKONADICALENDARTOOLS
++ FILE console.categories
++ DESTINATION ${KDE_INSTALL_LOGGINGCATEGORIESDIR}
++ )
+
+ ########### install files ###############
+
+--
+2.45.2
+