summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-07-14 17:13:32 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-07-15 07:36:14 +0200
commite19edabff80707de8772078358c8a9ca1169ca91 (patch)
treeb15a6cde4e36de6ddebe6a9e3d015312dc40dc8d /kde-apps/kaccounts-integration/kaccounts-integration-19.04.3.ebuild
parentkde5-functions.eclass: Update minimum deps (diff)
downloadgentoo-e19edabff80707de8772078358c8a9ca1169ca91.tar.gz
gentoo-e19edabff80707de8772078358c8a9ca1169ca91.tar.bz2
gentoo-e19edabff80707de8772078358c8a9ca1169ca91.zip
kde-apps: Add KDE Applications 19.04.3
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/kaccounts-integration/kaccounts-integration-19.04.3.ebuild')
-rw-r--r--kde-apps/kaccounts-integration/kaccounts-integration-19.04.3.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/kde-apps/kaccounts-integration/kaccounts-integration-19.04.3.ebuild b/kde-apps/kaccounts-integration/kaccounts-integration-19.04.3.ebuild
new file mode 100644
index 000000000000..3e554d7f971c
--- /dev/null
+++ b/kde-apps/kaccounts-integration/kaccounts-integration-19.04.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_TEST="forceoptional"
+VIRTUALDBUS_TEST="true"
+inherit kde5
+
+DESCRIPTION="Administer web accounts for the sites and services across the Plasma desktop"
+HOMEPAGE="https://community.kde.org/KTp"
+LICENSE="LGPL-2.1"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+BDEPEND="
+ sys-devel/gettext
+"
+COMMON_DEPEND="
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep kdeclarative)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ net-libs/accounts-qt
+ >=net-libs/libaccounts-glib-1.21
+ net-libs/signond
+"
+DEPEND="${COMMON_DEPEND}
+ $(add_frameworks_dep kcmutils)
+ $(add_plasma_dep kde-cli-tools)
+"
+RDEPEND="${COMMON_DEPEND}
+ dev-util/intltool
+"
+
+# bug #549444
+RESTRICT+=" test"