summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2017-06-08 23:00:50 +0200
committerJohannes Huber <johu@gentoo.org>2017-06-08 23:00:50 +0200
commitc892d3edb4099fe424a61b0d1aa296132d872ba0 (patch)
treee010db999c552c23e6993bd429516c40db852fe6 /kde-apps/kpimtextedit/kpimtextedit-17.04.2.ebuild
parentkde-frameworks/kdelibs: Version bump 4.14.33 (diff)
downloadgentoo-c892d3edb4099fe424a61b0d1aa296132d872ba0.tar.gz
gentoo-c892d3edb4099fe424a61b0d1aa296132d872ba0.tar.bz2
gentoo-c892d3edb4099fe424a61b0d1aa296132d872ba0.zip
kde-apps: Version bump KDE Applications 17.04.2
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'kde-apps/kpimtextedit/kpimtextedit-17.04.2.ebuild')
-rw-r--r--kde-apps/kpimtextedit/kpimtextedit-17.04.2.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/kde-apps/kpimtextedit/kpimtextedit-17.04.2.ebuild b/kde-apps/kpimtextedit/kpimtextedit-17.04.2.ebuild
new file mode 100644
index 000000000000..99cabebb5c06
--- /dev/null
+++ b/kde-apps/kpimtextedit/kpimtextedit-17.04.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_DESIGNERPLUGIN="true"
+KDE_TEST="true"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="A textedit with PIM-specific features"
+LICENSE="LGPL-2.1+"
+KEYWORDS="~amd64 ~x86"
+IUSE="speech"
+
+COMMON_DEPEND="
+ $(add_frameworks_dep kcodecs)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kemoticons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep sonnet)
+ $(add_frameworks_dep syntax-highlighting)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ dev-libs/grantlee:5
+ speech? ( $(add_qt_dep qtspeech) )
+"
+DEPEND="${COMMON_DEPEND}
+ test? ( $(add_frameworks_dep ktextwidgets) )
+"
+RDEPEND="${COMMON_DEPEND}
+ !kde-apps/kdepim-l10n
+"
+
+RESTRICT+=" test"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package speech Qt5TextToSpeech)
+ )
+
+ kde5_src_configure
+}