summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-01-10 09:30:23 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-01-10 16:50:00 +0100
commitf1b6a4697cb6bd8b01b005cca0996982fd736a2d (patch)
tree9b2799b0df1355e0ee40b8c909752698a0803837 /kde-apps/ktp-text-ui
parentapp-emulation/libvirt: init submodules for live ebuild (diff)
downloadgentoo-f1b6a4697cb6bd8b01b005cca0996982fd736a2d.tar.gz
gentoo-f1b6a4697cb6bd8b01b005cca0996982fd736a2d.tar.bz2
gentoo-f1b6a4697cb6bd8b01b005cca0996982fd736a2d.zip
kde-apps: Add KDE Applications 18.12.1
Package-Manager: Portage-2.3.54, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/ktp-text-ui')
-rw-r--r--kde-apps/ktp-text-ui/Manifest1
-rw-r--r--kde-apps/ktp-text-ui/ktp-text-ui-18.12.1.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/kde-apps/ktp-text-ui/Manifest b/kde-apps/ktp-text-ui/Manifest
index 521c2e5974d6..33d8da985391 100644
--- a/kde-apps/ktp-text-ui/Manifest
+++ b/kde-apps/ktp-text-ui/Manifest
@@ -1,2 +1,3 @@
DIST ktp-text-ui-18.08.3.tar.xz 469856 BLAKE2B 27bdcdec15cdaeb692194f1e085dae0e8d2d3a6f913b5631ffb7195b2a62ca8b37dd02971515ad31024704eedf8f5b1a4e3225f211461021ff550651a27e62a7 SHA512 a3d46895d501156ebb6727e3b5bd6b4c0b6f202a77d5cdf557c6a15658d514ea692cc3f1cdeb59e18d45cdedc1387225816655e0c6e129b78ed8e7a6c1cd5444
DIST ktp-text-ui-18.12.0.tar.xz 465828 BLAKE2B 8f80c009fe405bd7398b349d78e53f9a57e097a8b7e6fb9305af6880b4a016a3383cf58858b99166ca0fad9ebd2829ec4133fe068506a603ba07d084464a997e SHA512 db11b82075c5a3ad6416445e427268a590fe51f5d94e010a0b72413cefe711a1a951fe2c4677cfd912a5d038bce2e32053f524c08bdbf3f44406c6678ddb10a5
+DIST ktp-text-ui-18.12.1.tar.xz 465884 BLAKE2B 659ffbf80cfde4d42d691c0d1eea1bb8a5fe1f05f46d1fa49addd154d597e50259a60d49b1a0c24361a09ca51ad2f5ceb1d31dc190dbf98d5fd851a76f18f14c SHA512 17e48cbb5646cce61be7e775a742a491ef7ab9a44136eb224fcb0ba9d35bc3162b2887c291a6e39ba8f16198b107acaf0763b6d41213e949e9407da859f1b944
diff --git a/kde-apps/ktp-text-ui/ktp-text-ui-18.12.1.ebuild b/kde-apps/ktp-text-ui/ktp-text-ui-18.12.1.ebuild
new file mode 100644
index 000000000000..793df4dc4d4e
--- /dev/null
+++ b/kde-apps/ktp-text-ui/ktp-text-ui-18.12.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit kde5
+
+DESCRIPTION="KDE Telepathy text chat window"
+HOMEPAGE="https://community.kde.org/Real-Time_Communication_and_Collaboration"
+
+LICENSE="Apache-2.0 || ( AFL-2.1 BSD ) GPL-2+ LGPL-2.1+ MIT"
+KEYWORDS="~amd64 ~x86"
+IUSE="speech"
+
+DEPEND="
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep kemoticons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep knotifyconfig)
+ $(add_frameworks_dep kpeople)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep sonnet)
+ $(add_kdeapps_dep ktp-common-internals otr)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwebengine 'widgets')
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ net-libs/telepathy-qt[qt5(+)]
+ speech? ( $(add_qt_dep qtspeech) )
+"
+RDEPEND="${DEPEND}
+ $(add_kdeapps_dep ktp-contact-list)
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package speech Qt5TextToSpeech)
+ )
+
+ kde5_src_configure
+}