summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-03-16 21:52:25 +0000
committerSam James <sam@gentoo.org>2022-03-16 21:52:25 +0000
commit2661c867b5cf47e49bed24b40607b39b8a4c966a (patch)
tree1b2085b80888f1f597b7f70a2313092045f638ed /kde-apps
parentdev-python/redis-py: Remove old (diff)
downloadgentoo-2661c867b5cf47e49bed24b40607b39b8a4c966a.tar.gz
gentoo-2661c867b5cf47e49bed24b40607b39b8a4c966a.tar.bz2
gentoo-2661c867b5cf47e49bed24b40607b39b8a4c966a.zip
kde-apps/libkgapi: skip buggy tests
We want to report these failures upstream but I didn't think ahead and upgraded to newer Qt 5.15.3 (not yet in wider distribution yet in Gentoo) and some of the newer failures I hit may be attributed to that. So, let's skip them for now, and circle back. Other distros (Exherbo, Alpine) are hitting these failures anyway so we know it's not Gentoo-specific. Bug: https://bugs.gentoo.org/832709 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'kde-apps')
-rw-r--r--kde-apps/libkgapi/libkgapi-21.12.3.ebuild12
1 files changed, 12 insertions, 0 deletions
diff --git a/kde-apps/libkgapi/libkgapi-21.12.3.ebuild b/kde-apps/libkgapi/libkgapi-21.12.3.ebuild
index cd70cf990abc..cb1ee520c959 100644
--- a/kde-apps/libkgapi/libkgapi-21.12.3.ebuild
+++ b/kde-apps/libkgapi/libkgapi-21.12.3.ebuild
@@ -31,3 +31,15 @@ DEPEND="
>=kde-frameworks/kwallet-${KFMIN}:5
"
RDEPEND="${DEPEND}"
+
+src_test() {
+ local myctestargs=(
+ # Both fail for multiple distros, see bug #832709 for more discussion
+ # Revisit at least once Qt 5.15.3 is in wider distribution (in Gentoo at least):
+ # - contacts-contactcreatejobtest
+ # - contacts-contactmodifyjobtest
+ -E "(contacts-contactcreatejobtest|contacts-contactmodifyjobtest"
+ )
+
+ virtx cmake_src_test
+}